summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorbbangert <none@none>2005-09-18 12:46:16 -0700
committerbbangert <none@none>2005-09-18 12:46:16 -0700
commitbdb8ce395ef2765c2752a5b1e5b26a3a3862f69f (patch)
tree38f3fc3126683d8d5f4a89b09d9933f48305393c /setup.py
parent22e4311b78416ee6e7e4a6a7313c08e565ff8117 (diff)
downloadroutes-bdb8ce395ef2765c2752a5b1e5b26a3a3862f69f.tar.gz
[svn] Prepping for 0.1 release
--HG-- branch : trunk
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py17
1 files changed, 10 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index bc903a5..28817c2 100644
--- a/setup.py
+++ b/setup.py
@@ -2,19 +2,22 @@ from ez_setup import use_setuptools
use_setuptools()
from setuptools import setup, find_packages
-import sys
-import os
-from distutils.core import setup
-
setup(name="Routes",
version='0.1',
description='Routing Recognition and Generation Tools',
long_description="""
-A Routing package for Python that directly support 98% of the Rails unit tests
+A Routing package for Python that matches URL's to dicts and vice versa
""",
+ classifiers=["Development Status :: 1 - Beta",
+ "Intended Audience :: Web Framework Developers",
+ "License :: OSI Approved :: New BSD License",
+ "Programming Language :: Python",
+ "Topic :: Internet :: WWW/HTTP",
+ "Topic :: Internet :: WWW/HTTP :: URL Resolver",
+ "Topic :: Software Development :: Libraries :: Python Modules",
+ ],
author='Ben Bangert',
author_email='ben@groovie.org',
url='http://routes.groovie.org/',
packages=find_packages(exclude='tests'),
- )
-
+ ) \ No newline at end of file