summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--README.rst4
-rw-r--r--setup.py6
2 files changed, 10 insertions, 0 deletions
diff --git a/README.rst b/README.rst
index e40c921..676d977 100644
--- a/README.rst
+++ b/README.rst
@@ -7,3 +7,7 @@ Speedy and dynamic URL generation means you get a URL with minimal cruft
on repetitive typing.
See `the documentation for installation and usage of Routes <http://readthedocs.org/docs/routes/en/latest/>`_.
+
+.. image:: https://github.com/bbangert/routes/workflows/Python%20package/badge.svg?branch=main&event=push
+ :target: https://github.com/cherrypy/cheroot/actions?query=workflow%3A%22Python+package%22+branch%3Amaster
+ :alt: GitHub Actions Workflows CI/CD
diff --git a/setup.py b/setup.py
index 5d97b11..18d886f 100644
--- a/setup.py
+++ b/setup.py
@@ -55,6 +55,12 @@ setup(name="Routes",
author="Ben Bangert",
author_email="ben@groovie.org",
url='https://routes.readthedocs.io/',
+ project_urls={
+ 'CI: GitHub': 'https://github.com/bbangert/routes/actions?query=branch:main',
+ 'Docs: RTD': 'https://routes.readthedocs.io/',
+ 'GitHub: issues': 'https://github.com/bbangert/routes/issues',
+ 'GitHub: repo': 'https://github.com/bbangert/routes',
+ },
license="MIT",
test_suite="nose.collector",
include_package_data=True,