summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGELOG4
-rw-r--r--routes/util.py9
-rw-r--r--setup.py2
3 files changed, 6 insertions, 9 deletions
diff --git a/CHANGELOG b/CHANGELOG
index 1ff6593..961883a 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,6 +1,10 @@
Routes Changelog
========================
+-- 1.9.2 (July 8, 2008)
+* Fixed bug in url_for which caused it to return a literal when it shouldn't
+ have.
+
-- 1.9.1 (June 28, 2008)
* Fixed bug in formatted route recognition with formatting being absorbed
into the id.
diff --git a/routes/util.py b/routes/util.py
index 08e4950..df4c05d 100644
--- a/routes/util.py
+++ b/routes/util.py
@@ -10,13 +10,6 @@ import re
import urllib
from routes import request_config
-class literal(str):
- """Literal class for use in systems to indicate the url is already
- escaped"""
- def __html__(self):
- return self
-
-
def _screenargs(kargs):
"""
Private function that takes a dict, and screens it against the current
@@ -244,7 +237,7 @@ def url_for(*args, **kargs):
raise RouteException(
"url_for could not generate URL. Called with args: %s %s" % \
(args, kargs))
- return literal(url)
+ return url
def redirect_to(*args, **kargs):
"""Issues a redirect based on the arguments.
diff --git a/setup.py b/setup.py
index d219321..8d3c403 100644
--- a/setup.py
+++ b/setup.py
@@ -5,7 +5,7 @@ except ImportError:
use_setuptools()
from setuptools import setup, find_packages
-version = '1.9.1'
+version = '1.9.2'
setup(name="Routes",
version=version,