summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSelwin Ong <selwin.ong@gmail.com>2020-05-13 08:10:29 +0700
committerSelwin Ong <selwin.ong@gmail.com>2020-05-13 08:10:29 +0700
commit02eb983e90aeb8e878e5c0f9989b7b701b8ad21a (patch)
tree387bf78cfa7b093adb00b2ac0dee993aa99de630
parent9d6f38df0e7629962004f82021e0ed45dd488e2c (diff)
downloadrq-02eb983e90aeb8e878e5c0f9989b7b701b8ad21a.tar.gz
Bump version to 1.4.0v1.4.0
-rw-r--r--CHANGES.md8
-rw-r--r--rq/version.py2
-rw-r--r--setup.py2
3 files changed, 10 insertions, 2 deletions
diff --git a/CHANGES.md b/CHANGES.md
index 5b71d17..3dd3076 100644
--- a/CHANGES.md
+++ b/CHANGES.md
@@ -1,3 +1,11 @@
+### RQ 1.4.0 (2020-05-13)
+* Custom serializer is now supported. Thanks @solababs!
+* `delay()` now accepts `job_id` argument. Thanks @grayshirt!
+* Fixed a bug that may cause early termination of scheduled or requeued jobs. Thanks @rmartin48!
+* When a job is scheduled, always add queue name to a set containing active RQ queue names. Thanks @mdawar!
+* Added `--sentry-ca-certs` and `--sentry-debug` parameters to `rq worker` CLI. Thanks @kichawa!
+* Jobs cleaned up by `StartedJobRegistry` are given an exception info. Thanks @selwin!
+
### RQ 1.3.0 (2020-03-09)
* Support for infinite job timeout. Thanks @theY4Kman!
* Added `__main__` file so you can now do `python -m rq.cli`. Thanks @bbayles!
diff --git a/rq/version.py b/rq/version.py
index f75766e..8199df9 100644
--- a/rq/version.py
+++ b/rq/version.py
@@ -2,4 +2,4 @@
from __future__ import (absolute_import, division, print_function,
unicode_literals)
-VERSION = '1.3.0'
+VERSION = '1.4.0'
diff --git a/setup.py b/setup.py
index 8df1b72..046b3a8 100644
--- a/setup.py
+++ b/setup.py
@@ -35,7 +35,7 @@ setup(
'redis >= 3.0.0',
'click >= 5.0'
],
- python_requires='>=2.7',
+ python_requires='>=3.4',
entry_points={
'console_scripts': [
'rq = rq.cli:main',