summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorlowercase00 <21188280+lowercase00@users.noreply.github.com>2023-01-30 01:49:40 -0300
committerGitHub <noreply@github.com>2023-01-30 11:49:40 +0700
commit271e7a872735c49445b5b54855ff0e2b8992cbc9 (patch)
treebdcb2daa00666b09040452b7d14c35d2d9d894af
parent2c4c948207ae02976885dea693d418210e978f04 (diff)
downloadrq-271e7a872735c49445b5b54855ff0e2b8992cbc9.tar.gz
Add 3.11 Support (#1780)
-rw-r--r--.github/workflows/dependencies.yml4
-rw-r--r--.github/workflows/workflow.yml2
-rw-r--r--setup.py2
3 files changed, 5 insertions, 3 deletions
diff --git a/.github/workflows/dependencies.yml b/.github/workflows/dependencies.yml
index 6490553..b2b5915 100644
--- a/.github/workflows/dependencies.yml
+++ b/.github/workflows/dependencies.yml
@@ -13,7 +13,7 @@ jobs:
runs-on: ubuntu-20.04
strategy:
matrix:
- python-version: ["3.6", "3.7", "3.8.3", "3.9", "3.10"]
+ python-version: ["3.6", "3.7", "3.8.3", "3.9", "3.10", "3.11"]
redis-version: [3, 4, 5, 6, 7]
redis-py-version: [3.5.0]
@@ -49,7 +49,7 @@ jobs:
strategy:
matrix:
- python-version: ["3.6", "3.7", "3.8.3", "3.9", "3.10"]
+ python-version: ["3.6", "3.7", "3.8.3", "3.9", "3.10", "3.11"]
redis-version: [3, 4, 5, 6, 7]
steps:
diff --git a/.github/workflows/workflow.yml b/.github/workflows/workflow.yml
index 05f3751..d089f80 100644
--- a/.github/workflows/workflow.yml
+++ b/.github/workflows/workflow.yml
@@ -15,7 +15,7 @@ jobs:
runs-on: ubuntu-20.04
strategy:
matrix:
- python-version: ["3.6", "3.7", "3.8.3", "3.9", "3.10"]
+ python-version: ["3.6", "3.7", "3.8.3", "3.9", "3.10", "3.11"]
redis-version: [3, 4, 5, 6, 7]
redis-py-version: [3.5.0]
diff --git a/setup.py b/setup.py
index bc6d4b1..d60465e 100644
--- a/setup.py
+++ b/setup.py
@@ -76,6 +76,8 @@ setup(
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3.9',
+ 'Programming Language :: Python :: 3.10',
+ 'Programming Language :: Python :: 3.11',
'Topic :: Software Development :: Libraries :: Python Modules',
'Topic :: Internet',
'Topic :: Scientific/Engineering',