summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2020-07-06 14:26:12 -1000
committerGitHub <noreply@github.com>2020-07-07 07:26:12 +0700
commit8432a916bd07bdad8189ad2fc6c53694c8a750ce (patch)
tree535a9c535b143311d4c52e2ab49e56c08570017f
parent0b55981631658d337bf48b5919a2569dbb4175fd (diff)
downloadrq-8432a916bd07bdad8189ad2fc6c53694c8a750ce.tar.gz
setup: Set min Python version to 3.5 (#1291)
As `redis-py` in version 3.5.0 is now required, whoch only support Python 3.5+, we should remove Python 3.4 from the supported Python versions as well. Signed-off-by: Paul Spooren <mail@aparcar.org>
-rw-r--r--setup.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 7069774..ac40818 100644
--- a/setup.py
+++ b/setup.py
@@ -41,7 +41,7 @@ setup(
zip_safe=False,
platforms='any',
install_requires=get_requirements(),
- python_requires='>=3.4',
+ python_requires='>=3.5',
entry_points={
'console_scripts': [
'rq = rq.cli:main',
@@ -72,7 +72,6 @@ setup(
'Operating System :: Unix',
'Programming Language :: Python',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',