summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRob Hudson <robhudson@mozilla.com>2023-05-17 09:19:14 -0700
committerGitHub <noreply@github.com>2023-05-17 23:19:14 +0700
commitea063edf0a790630d0800808fe6236b3e9ddcf22 (patch)
treeead2cb88df0fd1a7b4d03f578d9aa9692381e566 /setup.py
parentbbfeb8c8ed2913e980412ee7606c171fdf37e713 (diff)
downloadrq-ea063edf0a790630d0800808fe6236b3e9ddcf22.tar.gz
Update linting configuration (#1915)
* Update linting configuration This removes flake8 in favor of ruff, which also provides isort support, and updates all files to be black, isort, and ruff compliant. This also adds black and ruff checks to the tox and Github linting workflow. * Tweak the code coverage config and calls
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py12
1 files changed, 5 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index 221e223..ceaf034 100644
--- a/setup.py
+++ b/setup.py
@@ -3,7 +3,8 @@ rq is a simple, lightweight, library for creating background jobs, and
processing them.
"""
import os
-from setuptools import setup, find_packages
+
+from setuptools import find_packages, setup
def get_version():
@@ -33,11 +34,10 @@ setup(
license='BSD',
author='Vincent Driessen',
author_email='vincent@3rdcloud.com',
- description='RQ is a simple, lightweight, library for creating background '
- 'jobs, and processing them.',
+ description='RQ is a simple, lightweight, library for creating background jobs, and processing them.',
long_description=__doc__,
packages=find_packages(exclude=['tests', 'tests.*']),
- package_data = {"rq": ["py.typed"]},
+ package_data={"rq": ["py.typed"]},
include_package_data=True,
zip_safe=False,
platforms='any',
@@ -46,7 +46,6 @@ setup(
entry_points={
'console_scripts': [
'rq = rq.cli:main',
-
# NOTE: rqworker/rqinfo are kept for backward-compatibility,
# remove eventually (TODO)
'rqinfo = rq.cli:info',
@@ -85,6 +84,5 @@ setup(
'Topic :: System :: Distributed Computing',
'Topic :: System :: Systems Administration',
'Topic :: System :: Monitoring',
-
- ]
+ ],
)