summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJon Parise <jon@indelible.org>2012-10-04 16:57:49 -0700
committerJon Parise <jon@indelible.org>2012-10-04 16:57:49 -0700
commiteb00f69cedea624cee5bf91eccde963cc1c35956 (patch)
treeb44c5006d517f567718e87a6eb0e5ae983e7d24f /setup.py
parentb97a9df69ca13a54de65c716e06b9ffc3c618c55 (diff)
downloadrq-eb00f69cedea624cee5bf91eccde963cc1c35956.tar.gz
Add a standard --url argument to all scripts.
redis-py now supports URL-based connection configuration. When --url is specified, we use it to construct the Redis object. Otherwise, we use the existing argument-based construction method. `Redis.from_url()` is new in redis-py 2.6.2, so that prerequisite has been adjusted accordingly.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 044bf8d..a5f989a 100644
--- a/setup.py
+++ b/setup.py
@@ -17,7 +17,7 @@ def get_version():
def get_dependencies():
- deps = ['redis >= 2.4.0', 'times']
+ deps = ['redis >= 2.6.2', 'times']
deps += ['logbook'] # should be soft dependency?
if sys.version_info < (2, 7) or \
(sys.version_info >= (3, 0) and sys.version_info < (3, 1)):