summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSybren A. Stüvel <sybren@stuvel.eu>2018-09-16 13:42:15 +0200
committerSybren A. Stüvel <sybren@stuvel.eu>2018-09-16 13:42:15 +0200
commit368a31f431f24843189b5d4da6b8530fa8bd47d8 (patch)
tree81d0770aaf9aae9d7db0798d2adb4ae2f4bf44cf
parent0d13454e8598157d9c1500e7463737c9c28c4710 (diff)
downloadrsa-git-version-4.0.tar.gz
Mark 4.0 as releasedversion-4.0
-rw-r--r--CHANGELOG.txt2
-rw-r--r--doc/conf.py2
-rw-r--r--rsa/__init__.py4
-rwxr-xr-xsetup.py2
4 files changed, 5 insertions, 5 deletions
diff --git a/CHANGELOG.txt b/CHANGELOG.txt
index ca58abf..f8ed650 100644
--- a/CHANGELOG.txt
+++ b/CHANGELOG.txt
@@ -1,7 +1,7 @@
Python-RSA changelog
========================================
-Version 4.0 - in development
+Version 4.0 - released 2018-09-16
----------------------------------------
- Removed deprecated modules:
diff --git a/doc/conf.py b/doc/conf.py
index f209a4d..3331a86 100644
--- a/doc/conf.py
+++ b/doc/conf.py
@@ -46,7 +46,7 @@ master_doc = 'index'
# General information about the project.
project = u'Python-RSA'
-copyright = u'2011-2017, Sybren A. Stüvel'
+copyright = u'2011-2018, Sybren A. Stüvel'
# The version info for the project you're documenting, acts as replacement for
# |version| and |release|, also used in various other places throughout the
diff --git a/rsa/__init__.py b/rsa/__init__.py
index ce3a341..9b05c6c 100644
--- a/rsa/__init__.py
+++ b/rsa/__init__.py
@@ -28,8 +28,8 @@ from rsa.pkcs1 import encrypt, decrypt, sign, verify, DecryptionError, \
VerificationError, find_signature_hash, sign_hash, compute_hash
__author__ = "Sybren Stuvel, Barry Mead and Yesudeep Mangalapilly"
-__date__ = "2016-03-29"
-__version__ = '4.0-alpha'
+__date__ = "2018-09-16"
+__version__ = '4.0'
# Do doctest if we're run directly
if __name__ == "__main__":
diff --git a/setup.py b/setup.py
index 5fccadb..18f339e 100755
--- a/setup.py
+++ b/setup.py
@@ -21,7 +21,7 @@ with open('README.md') as f:
if __name__ == '__main__':
setup(name='rsa',
- version='4.0-alpha',
+ version='4.0',
description='Pure-Python RSA implementation',
long_description=long_description,
long_description_content_type='text/markdown',