summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSybren A. Stüvel <sybren@stuvel.eu>2020-06-12 22:22:14 +0200
committerSybren A. Stüvel <sybren@stuvel.eu>2020-06-12 22:22:14 +0200
commit4834b903bb91fd05a2c9c8d5f4255ae0169ba6e7 (patch)
tree44346c30768672b473c05fa2d82a75452ad509a4
parent4d3025ff38c6af4905fd416c7951a74f7bf74ba7 (diff)
downloadrsa-git-version-4.3-py27compatible.tar.gz
-rw-r--r--CHANGELOG.txt10
-rw-r--r--rsa/__init__.py2
-rwxr-xr-xsetup.py2
3 files changed, 8 insertions, 6 deletions
diff --git a/CHANGELOG.txt b/CHANGELOG.txt
index b49f25d..993c802 100644
--- a/CHANGELOG.txt
+++ b/CHANGELOG.txt
@@ -1,12 +1,14 @@
Python-RSA changelog
========================================
-Version 4.3 - released 2020-06-12
+Version 4.3 & 4.5 - released 2020-06-12
----------------------------------------
-Version 4.3 is almost a re-tagged release of version 4.0. It is the last to
-support Python 2.7. This is now made explicit in the `python_requires` argument
-in `setup.py`. Python 3.4 is not supported by this release.
+Version 4.3 and 4.5 are almost a re-tagged release of version 4.0. It is the
+last to support Python 2.7. This is now made explicit in the `python_requires`
+argument in `setup.py`. Python 3.4 is not supported by this release. There was a
+mistake releasing 4.4 as "3.5+ only", which made it necessary to retag 4.3 as
+4.5 as well.
Two security fixes have also been backported, so 4.3 = 4.0 + these two fixes.
diff --git a/rsa/__init__.py b/rsa/__init__.py
index 1fa8b1f..af5487f 100644
--- a/rsa/__init__.py
+++ b/rsa/__init__.py
@@ -29,7 +29,7 @@ from rsa.pkcs1 import encrypt, decrypt, sign, verify, DecryptionError, \
__author__ = "Sybren Stuvel, Barry Mead and Yesudeep Mangalapilly"
__date__ = "2020-06-12"
-__version__ = '4.3'
+__version__ = '4.5'
# Do doctest if we're run directly
if __name__ == "__main__":
diff --git a/setup.py b/setup.py
index 32edff6..c2a9684 100755
--- a/setup.py
+++ b/setup.py
@@ -21,7 +21,7 @@ with open('README.md') as f:
if __name__ == '__main__':
setup(name='rsa',
- version='4.3',
+ version='4.5',
description='Pure-Python RSA implementation',
long_description=long_description,
long_description_content_type='text/markdown',