summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHugo van Kemenade <hugovk@users.noreply.github.com>2021-10-10 21:16:26 +0300
committerSybren A. Stüvel <sybren@stuvel.eu>2021-11-03 11:14:14 +0100
commit1f779491022ef3549ac3dc23bb78d6d7a8122390 (patch)
tree6fc7f0ae56ccb3604ce0f0ff70154be6ffdbd511
parent483700ada63972e600c7770c124f5aa0568dabf7 (diff)
downloadrsa-git-1f779491022ef3549ac3dc23bb78d6d7a8122390.tar.gz
Add support for Python 3.10
-rw-r--r--.travis.yml1
-rw-r--r--pyproject.toml1
-rw-r--r--tox.ini2
3 files changed, 3 insertions, 1 deletions
diff --git a/.travis.yml b/.travis.yml
index 6d6442c..ca2f095 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -10,6 +10,7 @@ python:
- "3.7"
- "3.8"
- "3.9"
+ - "3.10-dev"
install:
- pip install -U pip setuptools # https://github.com/pypa/virtualenv/issues/1630
diff --git a/pyproject.toml b/pyproject.toml
index d5fd5ab..aad9df8 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -19,6 +19,7 @@ classifiers = [
"Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
+ "Programming Language :: Python :: 3.10",
"Programming Language :: Python :: Implementation :: CPython",
"Programming Language :: Python :: Implementation :: PyPy",
"Topic :: Security :: Cryptography",
diff --git a/tox.ini b/tox.ini
index 259849d..62bd0f7 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
# Environment changes have to be manually synced with '.travis.yml'.
-envlist = py36,p37,p38,p39
+envlist = py36,p37,p38,p39,py310
[pytest]
addopts = -v --cov rsa --cov-report term-missing