summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ziegenberg <daniel@ziegenberg.at>2022-11-18 16:58:47 +0100
committerSybren A. Stüvel <sybren@stuvel.eu>2023-04-23 15:11:03 +0200
commit462da901c7501af32f42003e0adbb16d4f1f7ddf (patch)
treefcde5ef7aae668cfca2174d83e0ac9c9cb904b7d
parent0b52e7401ce0f34939a03d6d8da747352a6a7b94 (diff)
downloadrsa-git-462da901c7501af32f42003e0adbb16d4f1f7ddf.tar.gz
Add support for Python 3.11
Signed-off-by: Daniel Ziegenberg <daniel@ziegenberg.at>
-rw-r--r--.travis.yml3
-rw-r--r--pyproject.toml1
-rw-r--r--tox.ini2
3 files changed, 4 insertions, 2 deletions
diff --git a/.travis.yml b/.travis.yml
index 1e95184..c5aa55a 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -9,7 +9,8 @@ python:
- "3.7"
- "3.8"
- "3.9"
- - "3.10-dev"
+ - "3.10"
+ - "3.11"
install:
- pip install -U pip setuptools # https://github.com/pypa/virtualenv/issues/1630
diff --git a/pyproject.toml b/pyproject.toml
index 5c36ed4..1dddc9c 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -20,6 +20,7 @@ classifiers = [
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
"Programming Language :: Python :: 3.10",
+ "Programming Language :: Python :: 3.11",
"Programming Language :: Python :: Implementation :: CPython",
"Programming Language :: Python :: Implementation :: PyPy",
"Topic :: Security :: Cryptography",
diff --git a/tox.ini b/tox.ini
index 809000e..a0a679f 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
# Environment changes have to be manually synced with '.travis.yml'.
-envlist = py37,py38,py39,py310
+envlist = py37,py38,py39,py310,py311
isolated_build = True
[pytest]