summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSybren A. Stüvel <sybren@stuvel.eu>2016-03-17 13:31:43 +0100
committerSybren A. Stüvel <sybren@stuvel.eu>2016-03-17 13:31:43 +0100
commit6b6d29789a15d328bb3887ea040707aa7ca77498 (patch)
tree0d19276632a063444184f7fa368152aec44c0a4d
parentbd4e213f07c45a8e932bf662ceb07926861775b1 (diff)
downloadrsa-git-6b6d29789a15d328bb3887ea040707aa7ca77498.tar.gz
Bumped to version 3.4
-rw-r--r--CHANGELOG.txt4
-rw-r--r--rsa/__init__.py4
-rwxr-xr-xsetup.py2
3 files changed, 5 insertions, 5 deletions
diff --git a/CHANGELOG.txt b/CHANGELOG.txt
index 63ddcf2..2fa4e44 100644
--- a/CHANGELOG.txt
+++ b/CHANGELOG.txt
@@ -2,7 +2,7 @@ Python-RSA changelog
========================================
-Version 3.4 - in development
+Version 3.4 - released 2006-03-17
----------------------------------------
- Moved development to Github: https://github.com/sybrenstuvel/python-rsa
@@ -13,10 +13,10 @@ Version 3.4 - in development
- Deprecated the old rsa._version133 and rsa._version200 submodules, they will be
completely removed in version 4.0.
- Add an 'exponent' argument to key.newkeys()
-- Fixed bugs #12, #14, #27, #30, #49
- Switched from Solovay-Strassen to Miller-Rabin primality testing, to
comply with NIST FIPS 186-4 [4] as probabilistic primality test
(Appendix C, subsection C.3):
+- Fixed bugs #12, #14, #27, #30, #49
[1] https://travis-ci.org/sybrenstuvel/python-rsa
[2] https://coveralls.io/github/sybrenstuvel/python-rsa
diff --git a/rsa/__init__.py b/rsa/__init__.py
index 3e591b8..0b287b8 100644
--- a/rsa/__init__.py
+++ b/rsa/__init__.py
@@ -29,8 +29,8 @@ from rsa.pkcs1 import encrypt, decrypt, sign, verify, DecryptionError, \
VerificationError
__author__ = "Sybren Stuvel, Barry Mead and Yesudeep Mangalapilly"
-__date__ = "2016-01-13"
-__version__ = '3.4-beta1'
+__date__ = "2016-03-17"
+__version__ = '3.4'
# Do doctest if we're run directly
if __name__ == "__main__":
diff --git a/setup.py b/setup.py
index 65fa9da..3b41d25 100755
--- a/setup.py
+++ b/setup.py
@@ -18,7 +18,7 @@ from setuptools import setup
if __name__ == '__main__':
setup(name='rsa',
- version='3.3',
+ version='3.4',
description='Pure-Python RSA implementation',
author='Sybren A. Stuvel',
author_email='sybren@stuvel.eu',