summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ziegenberg <daniel@ziegenberg.at>2022-11-18 17:11:35 +0100
committerDaniel Ziegenberg <daniel@ziegenberg.at>2022-12-06 18:48:42 +0100
commit9ae39fd37b9754d69398c3faa29b12ff5049ceb2 (patch)
tree9bd688d702fb25eccd4ed66c21a680810ee9a86f
parentc4dc7beb04bea05ed86adb2e4b7f780f173774b8 (diff)
downloadrsa-git-9ae39fd37b9754d69398c3faa29b12ff5049ceb2.tar.gz
Drop support for Python 3.6
Signed-off-by: Daniel Ziegenberg <daniel@ziegenberg.at>
-rw-r--r--.travis.yml1
-rw-r--r--README.md5
-rw-r--r--doc/installation.rst2
-rw-r--r--pyproject.toml3
-rw-r--r--tests/test_pkcs1.py1
-rw-r--r--tox.ini2
6 files changed, 3 insertions, 11 deletions
diff --git a/.travis.yml b/.travis.yml
index ca2f095..1e95184 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -6,7 +6,6 @@ cache: pip
# See: https://github.com/travis-ci/travis-ci/issues/3024
python:
- - "3.6"
- "3.7"
- "3.8"
- "3.9"
diff --git a/README.md b/README.md
index fae569b..f8d1986 100644
--- a/README.md
+++ b/README.md
@@ -64,13 +64,8 @@ index-servers =
```
. ./.venv/bin/activate
-pip install twine
poetry build
twine check dist/rsa-4.9.tar.gz dist/rsa-4.9-*.whl
twine upload -r rsa dist/rsa-4.9.tar.gz dist/rsa-4.9-*.whl
```
-
-The `pip install twine` is necessary as Python-RSA requires Python >= 3.6, and
-Twine requires at least version 3.7. This means Poetry refuses to add it as
-dependency.
diff --git a/doc/installation.rst b/doc/installation.rst
index 73f56e5..7d691d3 100644
--- a/doc/installation.rst
+++ b/doc/installation.rst
@@ -25,7 +25,7 @@ GitHub. It also hosts the `issue tracker`_.
Dependencies
------------
-Python-RSA is compatible with Python versions 3.5 and newer. The last
+Python-RSA is compatible with Python versions 3.7 and newer. The last
version with Python 2.7 support was Python-RSA 4.0.
Python-RSA has very few dependencies. As a matter of fact, to use it
diff --git a/pyproject.toml b/pyproject.toml
index d4ef8af..5c36ed4 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -16,7 +16,6 @@ classifiers = [
"Operating System :: OS Independent",
"Programming Language :: Python",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
@@ -32,7 +31,7 @@ include = [
]
[tool.poetry.dependencies]
-python = ">=3.6, <4"
+python = ">=3.7, <4"
pyasn1 = ">=0.1.3"
[tool.poetry.dev-dependencies]
diff --git a/tests/test_pkcs1.py b/tests/test_pkcs1.py
index a8b3cfd..1ce819f 100644
--- a/tests/test_pkcs1.py
+++ b/tests/test_pkcs1.py
@@ -101,7 +101,6 @@ class SignatureTest(unittest.TestCase):
signature = pkcs1.sign(message, self.priv, "SHA-256")
self.assertEqual("SHA-256", pkcs1.verify(message, signature, self.pub))
- @unittest.skipIf(sys.version_info < (3, 6), "SHA3 requires Python 3.6+")
def test_sign_verify_sha3(self):
"""Test happy flow of sign and verify with SHA3-256"""
diff --git a/tox.ini b/tox.ini
index 17e60b2..809000e 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
# Environment changes have to be manually synced with '.travis.yml'.
-envlist = py36,py37,py38,py39,py310
+envlist = py37,py38,py39,py310
isolated_build = True
[pytest]