summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSybren A. Stüvel <sybren@stuvel.eu>2020-06-12 22:24:49 +0200
committerSybren A. Stüvel <sybren@stuvel.eu>2020-06-12 22:24:49 +0200
commitcedefea7b455375e5a87200866809be59d718968 (patch)
treecfee14c593443a122a08b3134ea9e3c716f93744
parent9a70b0014f2b80328f274213df78ca90d554c28b (diff)
downloadrsa-git-cedefea7b455375e5a87200866809be59d718968.tar.gz
Retagged 4.4 as 4.6 and added bit of an explanation to CHANGELOG.mdversion-4.6
-rw-r--r--CHANGELOG.md23
-rw-r--r--rsa/__init__.py2
-rwxr-xr-xsetup.py2
3 files changed, 13 insertions, 14 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 736f487..0fa3054 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,25 +1,24 @@
# Python-RSA changelog
-## Version 4.4.1 - released 2020-06-12
+## Version 4.4 & 4.6 - released 2020-06-12
-This makes Python 3.8 support explicit in `setup.py`.
-
-
-## Version 4.4 - released 2020-06-12
-
-Version 4.3 is almost a re-tagged release of version 4.0. It requires Python
-3.5+. To avoid older Python installations from trying to upgrade to RSA 4.4,
-this is now made explicit in the `python_requires` argument in `setup.py`.
+Version 4.4 and 4.6 are almost a re-tagged release of version 4.2. It requires
+Python 3.5+. To avoid older Python installations from trying to upgrade to RSA
+4.4, this is now made explicit in the `python_requires` argument in `setup.py`.
+There was a mistake releasing 4.4 as "3.5+ only", which made it necessary to
+retag 4.4 as 4.6 as well.
No functional changes compared to version 4.2.
## Version 4.3 - released 2020-06-12
-Version 4.3 is almost a re-tagged release of version 4.0. It is the last to
-support Python 2.7. This is now made explicit in the `python_requires` argument
-in `setup.py`. Python 3.4 is not supported by this release.
+Version 4.3 and 4.5 are almost a re-tagged release of version 4.0. It is the
+last to support Python 2.7. This is now made explicit in the `python_requires`
+argument in `setup.py`. Python 3.4 is not supported by this release. There was a
+mistake releasing 4.4 as "3.5+ only", which made it necessary to retag 4.3 as
+4.5 as well.
Two security fixes have also been backported, so 4.3 = 4.0 + these two fixes.
diff --git a/rsa/__init__.py b/rsa/__init__.py
index 12523d8..1567dc1 100644
--- a/rsa/__init__.py
+++ b/rsa/__init__.py
@@ -27,7 +27,7 @@ from rsa.pkcs1 import encrypt, decrypt, sign, verify, DecryptionError, \
__author__ = "Sybren Stuvel, Barry Mead and Yesudeep Mangalapilly"
__date__ = '2020-06-12'
-__version__ = '4.4.1'
+__version__ = '4.6'
# Do doctest if we're run directly
if __name__ == "__main__":
diff --git a/setup.py b/setup.py
index 57db59d..2d22865 100755
--- a/setup.py
+++ b/setup.py
@@ -25,7 +25,7 @@ with open('README.md', encoding='utf-8') as f:
if __name__ == '__main__':
setup(name='rsa',
- version='4.4.1',
+ version='4.6',
description='Pure-Python RSA implementation',
long_description=long_description,
long_description_content_type='text/markdown',