summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorSybren A. Stüvel <sybren@stuvel.eu>2019-08-04 17:22:46 +0200
committerSybren A. Stüvel <sybren@stuvel.eu>2019-08-04 17:22:46 +0200
commit222fb5f44796c739b71afff74998e06ff22ca111 (patch)
treee7fa1778f6ca9d4cd8f5a832dc527b81ee3420b6 /pyproject.toml
parentb6cebd53fcafd3088fc8361f6d3466166f75410b (diff)
downloadrsa-git-222fb5f44796c739b71afff74998e06ff22ca111.tar.gz
Switch from Pipenv to Poetry
Poetry has a nicer interface, performs more tasks than Pipenv, and is generally more pleasant to use.
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml48
1 files changed, 48 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..776c6ab
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,48 @@
+[tool.poetry]
+name = "python-rsa"
+version = "4.1-dev0"
+license = "Apache-2.0"
+description = "Pure-Python RSA implementation"
+authors = ["Sybren A. Stüvel <sybren@stuvel.eu>"]
+homepage = "https://stuvel.eu/rsa"
+documentation = "https://stuvel.eu/python-rsa-doc/"
+repository = "https://github.com/sybrenstuvel/python-rsa/"
+classifiers=[
+ 'Development Status :: 5 - Production/Stable',
+ 'Intended Audience :: Developers',
+ 'Intended Audience :: Education',
+ 'Intended Audience :: Information Technology',
+ 'Operating System :: OS Independent',
+ 'Topic :: Security :: Cryptography',
+]
+
+packages = [
+ { include="rsa", from="." },
+]
+
+[tool.poetry.scripts]
+pyrsa-decrypt = "rsa.cli:decrypt"
+pyrsa-encrypt = "rsa.cli:encrypt"
+pyrsa-keygen = "rsa.cli:keygen"
+pyrsa-priv2pub = "rsa.util:private_to_public"
+pyrsa-sign = "rsa.cli:sign"
+pyrsa-verify = "rsa.cli:verify"
+
+
+[tool.poetry.dependencies]
+python = "^3.5"
+pyasn1 = ">=0.1.3"
+
+[tool.poetry.dev-dependencies]
+coveralls = "^1.8"
+Sphinx = "^2.1"
+pathlib2 = {version="^2.3.4", python="~3.5"}
+pytest = "^5.0"
+pytest-cov = "^2.7"
+tox = "^3.13"
+mypy = "^0.720"
+
+
+[build-system]
+requires = ["poetry>=0.12"]
+build-backend = "poetry.masonry.api"