summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorSybren A. Stüvel <sybren@stuvel.eu>2019-08-04 17:43:55 +0200
committerSybren A. Stüvel <sybren@stuvel.eu>2019-08-04 17:47:26 +0200
commit3c5ee594a2e38b27f086d042d9d2b9d7d0d0269d (patch)
treeb8caf816400742d66a547c21cfef950a6c3b3d9f /pyproject.toml
parentb68f6181e9729afc6cae42cdf12b6a8dba52a80e (diff)
downloadrsa-git-3c5ee594a2e38b27f086d042d9d2b9d7d0d0269d.tar.gz
Add support for SHA3 hashing
This is based on https://github.com/sybrenstuvel/python-rsa/pull/96, with a few improvements: - The minimum of one use of SHA3 in a unit test, to at least touch it at some point. - Documented the support of SHA3. - Only install the third-party library required by Python 3.5 when we're running on Python 3.5. Newer Python versions support SHA3 natively.
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 776c6ab..df54336 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -32,6 +32,7 @@ pyrsa-verify = "rsa.cli:verify"
[tool.poetry.dependencies]
python = "^3.5"
pyasn1 = ">=0.1.3"
+pysha3 = {version="^1.0", python="~3.5"}
[tool.poetry.dev-dependencies]
coveralls = "^1.8"