summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorSybren A. Stüvel <sybren@stuvel.eu>2021-02-16 20:15:39 +0100
committerSybren A. Stüvel <sybren@stuvel.eu>2021-02-24 12:44:41 +0100
commit8bc1ec89fb629a86cc5c74294dbe58ba2b2a8cef (patch)
treea53daa1a4493eb68c5be1053b8ae30f01ba78689 /pyproject.toml
parentf77fbdf515a3bf948453d9f8533f47e460533a1b (diff)
downloadrsa-git-8bc1ec89fb629a86cc5c74294dbe58ba2b2a8cef.tar.gz
Manage dependencies with Poetry instead of Pipenv
Poetry is nicer to work with than Pipenv + setup.py. This drops Python 3.5 support; that's ok, since that version is EOL.
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml53
1 files changed, 53 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..9c4f753
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,53 @@
+[tool.poetry]
+name = "rsa"
+version = "4.8-dev0"
+license = "Apache-2.0"
+description = "Pure-Python RSA implementation"
+readme = "README.md"
+authors = ["Sybren A. Stüvel <sybren@stuvel.eu>"]
+homepage = "https://stuvel.eu/rsa"
+classifiers = [
+ "Development Status :: 5 - Production/Stable",
+ "Intended Audience :: Developers",
+ "Intended Audience :: Education",
+ "Intended Audience :: Information Technology",
+ "License :: OSI Approved :: Apache Software License",
+ "Operating System :: OS Independent",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.6",
+ "Programming Language :: Python :: 3.7",
+ "Programming Language :: Python :: 3.8",
+ "Programming Language :: Python :: 3.9",
+ "Programming Language :: Python :: Implementation :: CPython",
+ "Programming Language :: Python :: Implementation :: PyPy",
+ "Topic :: Security :: Cryptography",
+]
+include = [
+ "LICENSE", "README.md", "CHANGELOG.md",
+]
+
+[tool.poetry.dependencies]
+python = ">=3.6, <4"
+pyasn1 = ">=0.1.3"
+
+[tool.poetry.dev-dependencies]
+coveralls = "^3.0.0"
+Sphinx = "^3.5.1"
+pytest = "^6.2.2"
+pytest-cov = "^2.11.1"
+tox = "^3.22.0"
+mypy = "^0.800"
+flake8 = "^3.8.4"
+
+[build-system]
+requires = ["poetry-core>=1.0.0"]
+build-backend = "poetry.core.masonry.api"
+
+[tool.poetry.scripts]
+"pyrsa-priv2pub" = "rsa.util:private_to_public"
+"pyrsa-keygen" = "rsa.cli:keygen"
+"pyrsa-encrypt" = "rsa.cli:encrypt"
+"pyrsa-decrypt" = "rsa.cli:decrypt"
+"pyrsa-sign" = "rsa.cli:sign"
+"pyrsa-verify" = "rsa.cli:verify"