summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorSybren A. Stüvel <sybren@stuvel.eu>2020-06-11 18:53:41 +0200
committerSybren A. Stüvel <sybren@stuvel.eu>2020-06-11 20:22:27 +0200
commitd15a7f3eaa90f2c48b6c4b893f4ae136a762b48f (patch)
tree847bb013a74481715a7a0f7ccba88a566f227023 /pyproject.toml
parent5c7696dd8a53b91b81346b1b04af8ef8e550707d (diff)
downloadrsa-git-d15a7f3eaa90f2c48b6c4b893f4ae136a762b48f.tar.gz
Moving back to Pipenv to manage dependencies
Poetry breaks no-binary installations of the RSA library, which defeats the purpose of this library. See https://github.com/sybrenstuvel/python-rsa/issues/148 Among other changes, this reverts commit fcf5b7457c70426a242b17db20dd4e34e1055f69. I also added a workaround for an `ImportError` importing `zipp` on Python 3.5.
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml50
1 files changed, 0 insertions, 50 deletions
diff --git a/pyproject.toml b/pyproject.toml
deleted file mode 100644
index ca337c8..0000000
--- a/pyproject.toml
+++ /dev/null
@@ -1,50 +0,0 @@
-[tool.poetry]
-name = "rsa"
-version = "4.2-dev0"
-license = "Apache-2.0"
-description = "Pure-Python RSA implementation"
-authors = ["Sybren A. Stüvel <sybren@stuvel.eu>"]
-homepage = "https://stuvel.eu/rsa"
-documentation = "https://stuvel.eu/python-rsa-doc/"
-repository = "https://github.com/sybrenstuvel/python-rsa/"
-classifiers=[
- 'Development Status :: 5 - Production/Stable',
- 'Intended Audience :: Developers',
- 'Intended Audience :: Education',
- 'Intended Audience :: Information Technology',
- 'Operating System :: OS Independent',
- 'Topic :: Security :: Cryptography',
-]
-
-packages = [
- { include="rsa", from="." },
-]
-
-[tool.poetry.scripts]
-pyrsa-decrypt = "rsa.cli:decrypt"
-pyrsa-encrypt = "rsa.cli:encrypt"
-pyrsa-keygen = "rsa.cli:keygen"
-pyrsa-priv2pub = "rsa.util:private_to_public"
-pyrsa-sign = "rsa.cli:sign"
-pyrsa-verify = "rsa.cli:verify"
-
-
-[tool.poetry.dependencies]
-python = "^3.5"
-pyasn1 = ">=0.1.3"
-pysha3 = {version="^1.0", python="~3.5"}
-
-[tool.poetry.dev-dependencies]
-coveralls = "^1.8"
-Sphinx = "^2.1"
-pathlib2 = {version="^2.3.4", python="~3.5"}
-pytest = "^5.0"
-pytest-cov = "^2.7"
-tox = "^3.13"
-mypy = "^0.720"
-flake8 = "^3.7"
-
-
-[build-system]
-requires = ["poetry>=0.12"]
-build-backend = "poetry.masonry.api"