summaryrefslogtreecommitdiff
path: root/update_version.sh
diff options
context:
space:
mode:
authorSybren A. Stüvel <sybren@stuvel.eu>2020-06-11 18:53:41 +0200
committerSybren A. Stüvel <sybren@stuvel.eu>2020-06-11 20:22:27 +0200
commitd15a7f3eaa90f2c48b6c4b893f4ae136a762b48f (patch)
tree847bb013a74481715a7a0f7ccba88a566f227023 /update_version.sh
parent5c7696dd8a53b91b81346b1b04af8ef8e550707d (diff)
downloadrsa-git-d15a7f3eaa90f2c48b6c4b893f4ae136a762b48f.tar.gz
Moving back to Pipenv to manage dependencies
Poetry breaks no-binary installations of the RSA library, which defeats the purpose of this library. See https://github.com/sybrenstuvel/python-rsa/issues/148 Among other changes, this reverts commit fcf5b7457c70426a242b17db20dd4e34e1055f69. I also added a workaround for an `ImportError` importing `zipp` on Python 3.5.
Diffstat (limited to 'update_version.sh')
-rwxr-xr-xupdate_version.sh5
1 files changed, 2 insertions, 3 deletions
diff --git a/update_version.sh b/update_version.sh
index 313b7a5..89c5447 100755
--- a/update_version.sh
+++ b/update_version.sh
@@ -9,11 +9,10 @@ DATE=$(date +'%Y-%m-%d')
sed "s/__date__\s=\s'[^']*'/__date__ = '$DATE'/" -i rsa/__init__.py
sed "s/__version__\s=\s'[^']*'/__version__ = '$1'/" -i rsa/__init__.py
-
-poetry version $1
+sed "s/version='[^']*'/version='$1'/" -i setup.py
git diff
echo
echo "Don't forget to commit and tag:"
-echo git commit -m \'Bumped version to $1\' pyproject.toml rsa/__init__.py
+echo git commit -m \'Bumped version to $1\' rsa/__init__.py setup.py
echo git tag -a version-$1 -m \'Tagged version $1\'