summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGELOG.md4
-rw-r--r--pyproject.toml4
2 files changed, 6 insertions, 2 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 554aac9..1cf67bd 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -3,9 +3,11 @@
## Version 4.9 - in development
- Remove debug logging from `rsa/key.py`
- ([#194](https://github.com/sybrenstuvel/python-rsa/pull/194)).
+ ([#194](https://github.com/sybrenstuvel/python-rsa/issues/194)).
- Remove overlapping slots in `PrivateKey` and `PublicKey`.
([#189](https://github.com/sybrenstuvel/python-rsa/pull/189)).
+- Do not include CHANGELOG/LICENSE/README.md in wheel
+ ([#191](https://github.com/sybrenstuvel/python-rsa/pull/191)).
## Version 4.8 - released 2021-11-24
diff --git a/pyproject.toml b/pyproject.toml
index 275eaa2..fcee728 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -26,7 +26,9 @@ classifiers = [
"Topic :: Security :: Cryptography",
]
include = [
- "LICENSE", "README.md", "CHANGELOG.md",
+ { path = "LICENSE", format = "sdist" },
+ { path = "README.md", format = "sdist" },
+ { path = "CHANGELOG.md", format = "sdist" },
]
[tool.poetry.dependencies]