summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-27 10:26:23 +0100
committerSybren A. Stüvel <sybren@stuvel.eu>2022-03-13 12:12:51 +0100
commit3031bf5c6ae64083431e849903b0104d2cfae893 (patch)
tree2ecd50101456a41532d670980404c515602a870f
parentc373662e16d3ea1b014ec2a26500b6c0603fcabd (diff)
downloadrsa-git-3031bf5c6ae64083431e849903b0104d2cfae893.tar.gz
Do not include arbitrary files in wheel
Fix the include key to apply to sdist format only. Otherwise, the listed files are added to the top directory of wheel as well and end up being installed in top-level site-packages directory, e.g.: * FILES:+usr/lib/python3.9/site-packages/CHANGELOG.md * FILES:+usr/lib/python3.9/site-packages/LICENSE * FILES:+usr/lib/python3.9/site-packages/README.md
-rw-r--r--CHANGELOG.md4
-rw-r--r--pyproject.toml4
2 files changed, 6 insertions, 2 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 554aac9..1cf67bd 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -3,9 +3,11 @@
## Version 4.9 - in development
- Remove debug logging from `rsa/key.py`
- ([#194](https://github.com/sybrenstuvel/python-rsa/pull/194)).
+ ([#194](https://github.com/sybrenstuvel/python-rsa/issues/194)).
- Remove overlapping slots in `PrivateKey` and `PublicKey`.
([#189](https://github.com/sybrenstuvel/python-rsa/pull/189)).
+- Do not include CHANGELOG/LICENSE/README.md in wheel
+ ([#191](https://github.com/sybrenstuvel/python-rsa/pull/191)).
## Version 4.8 - released 2021-11-24
diff --git a/pyproject.toml b/pyproject.toml
index 275eaa2..fcee728 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -26,7 +26,9 @@ classifiers = [
"Topic :: Security :: Cryptography",
]
include = [
- "LICENSE", "README.md", "CHANGELOG.md",
+ { path = "LICENSE", format = "sdist" },
+ { path = "README.md", format = "sdist" },
+ { path = "CHANGELOG.md", format = "sdist" },
]
[tool.poetry.dependencies]