summaryrefslogtreecommitdiff
path: root/doc/installation.rst
diff options
context:
space:
mode:
Diffstat (limited to 'doc/installation.rst')
-rw-r--r--doc/installation.rst24
1 files changed, 12 insertions, 12 deletions
diff --git a/doc/installation.rst b/doc/installation.rst
index 32dc257..e8f7170 100644
--- a/doc/installation.rst
+++ b/doc/installation.rst
@@ -1,13 +1,13 @@
Installation
============
-Installation can be done in various ways. The simplest form uses pip
-or easy_install. Either one will work::
+Installation can be done in various ways. The simplest form uses pip::
pip install rsa
Depending on your system you may need to use ``sudo pip`` if you want to install
-the library system-wide.
+the library system-wide, or use ``pip install --user rsa`` to install the
+library in your home directory.
Installation from source is also quite easy. Download the source and
then type::
@@ -25,6 +25,9 @@ GitHub. It also hosts the `issue tracker`_.
Dependencies
------------
+Python-RSA is compatible with Python versions 3.5 and newer. The last
+version with Python 2.7 support was Python-RSA 4.0.
+
Python-RSA has very few dependencies. As a matter of fact, to use it
you only need Python itself. Loading and saving keys does require an
extra module, though: pyasn1. If you used pip or easy_install like
@@ -34,17 +37,14 @@ described above, you should be ready to go.
Development dependencies
------------------------
-In order to start developing on Python-RSA you need a bit more. Use
-pip to install the development requirements in a virtual environment::
-
- virtualenv -p /path/to/your-python-version python-rsa-venv
- . python-rsa-venv/bin/activate
- pip install -r python-rsa/requirements.txt
+In order to start developing on Python-RSA, use Git_ to get a copy of
+the source::
+ git clone https://github.com/sybrenstuvel/python-rsa.git
-Once these are installed, use Git_ to get a copy of the source::
+Use pipenv_ to install the development requirements in a virtual environment::
- git clone https://github.com/sybrenstuvel/python-rsa.git
- python setup.py develop
+ pipenv install --dev
.. _Git: https://git-scm.com/
+.. _pipenv: https://docs.pipenv.org/