summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Kokkelkoren <roy.kokkelkoren@gmail.com>2015-10-25 16:12:11 +0100
committerRoy Kokkelkoren <roy.kokkelkoren@gmail.com>2015-10-25 16:12:11 +0100
commit827d7fb95bdb0293435d6ca18614e0c3f56f5135 (patch)
tree83c481164a03cd5e2cf2f39e5c19fd897ebc182d
parent1d611a04c34a1bccc415233d70fbb91059ace7ef (diff)
downloadrsa-827d7fb95bdb0293435d6ca18614e0c3f56f5135.tar.gz
Added per-file licenses
-rwxr-xr-xcreate_timing_table.py14
-rw-r--r--rsa/_version133.py15
-rw-r--r--rsa/_version200.py15
-rw-r--r--rsa/asn1.py15
-rw-r--r--run_tests.py14
-rwxr-xr-xsetup.py14
-rwxr-xr-xspeed.sh14
-rw-r--r--tests/constants.py14
-rw-r--r--tests/py2kconstants.py14
-rw-r--r--tests/py3kconstants.py14
-rw-r--r--tests/test_bigfile.py15
-rw-r--r--tests/test_common.py14
-rw-r--r--tests/test_compat.py14
-rw-r--r--tests/test_integers.py15
-rw-r--r--tests/test_load_save_keys.py15
-rw-r--r--tests/test_pem.py15
-rw-r--r--tests/test_pkcs1.py15
-rw-r--r--tests/test_strings.py15
-rw-r--r--tests/test_transform.py15
-rw-r--r--tests/test_varblock.py15
20 files changed, 289 insertions, 2 deletions
diff --git a/create_timing_table.py b/create_timing_table.py
index b1b2871..d2f4b2d 100755
--- a/create_timing_table.py
+++ b/create_timing_table.py
@@ -1,4 +1,18 @@
#!/usr/bin/env python
+#
+# Copyright 2011 Sybren A. Stüvel <sybren@stuvel.eu>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
import time
import rsa
diff --git a/rsa/_version133.py b/rsa/_version133.py
index 230a03c..38b2a36 100644
--- a/rsa/_version133.py
+++ b/rsa/_version133.py
@@ -1,3 +1,18 @@
+#
+# Copyright 2011 Sybren A. Stüvel <sybren@stuvel.eu>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
"""RSA module
pri = k[1] //Private part of keys d,p,q
diff --git a/rsa/_version200.py b/rsa/_version200.py
index f915653..9c38212 100644
--- a/rsa/_version200.py
+++ b/rsa/_version200.py
@@ -1,3 +1,18 @@
+#
+# Copyright 2011 Sybren A. Stüvel <sybren@stuvel.eu>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
"""RSA module
Module for calculating large primes, and RSA encryption, decryption,
diff --git a/rsa/asn1.py b/rsa/asn1.py
index 706e6cf..33dd69e 100644
--- a/rsa/asn1.py
+++ b/rsa/asn1.py
@@ -1,3 +1,18 @@
+#
+# Copyright 2011 Sybren A. Stüvel <sybren@stuvel.eu>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
'''ASN.1 definitions.
Not all ASN.1-handling code use these definitions, but when it does, they should be here.
diff --git a/run_tests.py b/run_tests.py
index e0f2490..10451d1 100644
--- a/run_tests.py
+++ b/run_tests.py
@@ -1,5 +1,19 @@
#!/usr/bin/env python
# -*- coding: utf-8 -*-
+#
+# Copyright 2011 Sybren A. Stüvel <sybren@stuvel.eu>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
import os
import sys
diff --git a/setup.py b/setup.py
index 9ddb8a6..75b2fe7 100755
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,18 @@
#!/usr/bin/env python
+#
+# Copyright 2011 Sybren A. Stüvel <sybren@stuvel.eu>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
from setuptools import setup
diff --git a/speed.sh b/speed.sh
index a57a527..c7b69cf 100755
--- a/speed.sh
+++ b/speed.sh
@@ -1,4 +1,18 @@
#!/bin/sh
+#
+# Copyright 2011 Sybren A. Stüvel <sybren@stuvel.eu>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
echo "int2bytes speed test"
echo "pypy"
diff --git a/tests/constants.py b/tests/constants.py
index 6a0d081..5eab9f2 100644
--- a/tests/constants.py
+++ b/tests/constants.py
@@ -1,4 +1,18 @@
# -*- coding: utf-8 -*-
+#
+# Copyright 2011 Sybren A. Stüvel <sybren@stuvel.eu>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
from rsa._compat import have_python3
diff --git a/tests/py2kconstants.py b/tests/py2kconstants.py
index 5f695dd..0b53a78 100644
--- a/tests/py2kconstants.py
+++ b/tests/py2kconstants.py
@@ -1,3 +1,17 @@
# -*- coding: utf-8 -*-
+#
+# Copyright 2011 Sybren A. Stüvel <sybren@stuvel.eu>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
unicode_string = u"Euro=\u20ac ABCDEFGHIJKLMNOPQRSTUVWXYZ"
diff --git a/tests/py3kconstants.py b/tests/py3kconstants.py
index 83b6712..c12a39b 100644
--- a/tests/py3kconstants.py
+++ b/tests/py3kconstants.py
@@ -1,3 +1,17 @@
# -*- coding: utf-8 -*-
+#
+# Copyright 2011 Sybren A. Stüvel <sybren@stuvel.eu>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
unicode_string = "Euro=\u20ac ABCDEFGHIJKLMNOPQRSTUVWXYZ"
diff --git a/tests/test_bigfile.py b/tests/test_bigfile.py
index 86bcbba..03863c1 100644
--- a/tests/test_bigfile.py
+++ b/tests/test_bigfile.py
@@ -1,3 +1,18 @@
+#
+# Copyright 2011 Sybren A. Stüvel <sybren@stuvel.eu>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
'''Tests block operations.'''
from rsa._compat import b
diff --git a/tests/test_common.py b/tests/test_common.py
index d105dc0..eba5d27 100644
--- a/tests/test_common.py
+++ b/tests/test_common.py
@@ -1,5 +1,19 @@
#!/usr/bin/env python
# -*- coding: utf-8 -*-
+#
+# Copyright 2011 Sybren A. Stüvel <sybren@stuvel.eu>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
import unittest2
import struct
diff --git a/tests/test_compat.py b/tests/test_compat.py
index 3652c82..1788ff0 100644
--- a/tests/test_compat.py
+++ b/tests/test_compat.py
@@ -1,4 +1,18 @@
# -*- coding: utf-8 -*-
+#
+# Copyright 2011 Sybren A. Stüvel <sybren@stuvel.eu>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
import unittest2
import struct
diff --git a/tests/test_integers.py b/tests/test_integers.py
index 0a712aa..58af48c 100644
--- a/tests/test_integers.py
+++ b/tests/test_integers.py
@@ -1,3 +1,18 @@
+#
+# Copyright 2011 Sybren A. Stüvel <sybren@stuvel.eu>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
'''Tests integer operations.'''
import unittest2
diff --git a/tests/test_load_save_keys.py b/tests/test_load_save_keys.py
index fc1a1aa..0d132b9 100644
--- a/tests/test_load_save_keys.py
+++ b/tests/test_load_save_keys.py
@@ -1,3 +1,18 @@
+#
+# Copyright 2011 Sybren A. Stüvel <sybren@stuvel.eu>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
'''Unittest for saving and loading keys.'''
import base64
diff --git a/tests/test_pem.py b/tests/test_pem.py
index 867f678..d1dcf3a 100644
--- a/tests/test_pem.py
+++ b/tests/test_pem.py
@@ -1,6 +1,19 @@
#!/usr/bin/env python
# -*- coding: utf-8 -*-
-
+#
+# Copyright 2011 Sybren A. Stüvel <sybren@stuvel.eu>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
import unittest2
from rsa._compat import b
diff --git a/tests/test_pkcs1.py b/tests/test_pkcs1.py
index d5882df..4be2dd8 100644
--- a/tests/test_pkcs1.py
+++ b/tests/test_pkcs1.py
@@ -1,3 +1,18 @@
+#
+# Copyright 2011 Sybren A. Stüvel <sybren@stuvel.eu>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
'''Tests string operations.'''
import struct
diff --git a/tests/test_strings.py b/tests/test_strings.py
index 4af0629..e307efb 100644
--- a/tests/test_strings.py
+++ b/tests/test_strings.py
@@ -1,3 +1,18 @@
+#
+# Copyright 2011 Sybren A. Stüvel <sybren@stuvel.eu>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
'''Tests string operations.'''
from __future__ import absolute_import
diff --git a/tests/test_transform.py b/tests/test_transform.py
index ffd9ec8..ed3e38b 100644
--- a/tests/test_transform.py
+++ b/tests/test_transform.py
@@ -1,5 +1,18 @@
# -*- coding: utf-8 -*-
-
+#
+# Copyright 2011 Sybren A. Stüvel <sybren@stuvel.eu>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
import unittest2
from rsa._compat import b
diff --git a/tests/test_varblock.py b/tests/test_varblock.py
index 24ea50f..6dad5ab 100644
--- a/tests/test_varblock.py
+++ b/tests/test_varblock.py
@@ -1,3 +1,18 @@
+#
+# Copyright 2011 Sybren A. Stüvel <sybren@stuvel.eu>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
'''Tests varblock operations.'''