summaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorSybren A. St?vel <sybren@stuvel.eu>2012-06-18 16:34:20 +0200
committerSybren A. St?vel <sybren@stuvel.eu>2012-06-18 16:34:20 +0200
commit2063cbb255f171c8a0e5b7d5bf3b691bcd8dfec5 (patch)
tree4570924ac130df411eea9219dd9afcd90c6d435c /doc
parentb5b5a0b628db24248013accda62f9f1894c2f179 (diff)
downloadrsa-2063cbb255f171c8a0e5b7d5bf3b691bcd8dfec5.tar.gz
Updated installation instructions
Diffstat (limited to 'doc')
-rw-r--r--doc/Makefile7
-rw-r--r--doc/installation.rst23
2 files changed, 20 insertions, 10 deletions
diff --git a/doc/Makefile b/doc/Makefile
index 397d629..5eaf772 100644
--- a/doc/Makefile
+++ b/doc/Makefile
@@ -130,3 +130,10 @@ doctest:
$(SPHINXBUILD) -b doctest $(ALLSPHINXOPTS) $(BUILDDIR)/doctest
@echo "Testing of doctests in the sources finished, look at the " \
"results in $(BUILDDIR)/doctest/output.txt."
+
+upload: html
+ @echo
+ @echo "UPLOADING to webserver"
+ @echo
+ rsync _build/html/* sybren@stuvel.eu:stuvel.eu/manager/files/python-rsa-doc/ -va
+
diff --git a/doc/installation.rst b/doc/installation.rst
index 0880d6f..afe093f 100644
--- a/doc/installation.rst
+++ b/doc/installation.rst
@@ -41,19 +41,22 @@ Development dependencies
--------------------------------------------------
In order to start developing on Python-RSA you need a bit more. Use
-pip or easy_install to install the following packages:
+pip to install the development requirements in a virtual environment
+for Python 2.x::
- - Mercurial
- - nose
- - sphinx
- - pyasn1
- - tox
- - unittest2 (Python 2.x) or unittest2py3k (Python 3.x)
+ virtualenv python-rsa-venv-py2x
+ . python-rsa-venv-py2x/bin/activate
+ pip install -r python-rsa/requirements-dev-py2x.txt
-Once these are installed, use Mercurial_ to get a copy of the source::
+or Python 3.x::
+
+ virtualenv python-rsa-venv-py3x
+ . python-rsa-venv-py3x/bin/activate
+ pip install -r python-rsa/requirements-dev-py3x.txt
- hg clone https://sybren@bitbucket.org/sybren/python-rsa
- sudo python setup.py develop
+Once these are installed, use Mercurial_ to get a copy of the source::
+ hg clone https://bitbucket.org/sybren/python-rsa
+ python setup.py develop
.. _Mercurial: http://hg-scm.com/