summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndy Grover <agrover@redhat.com>2015-04-23 10:07:58 -0700
committerAndy Grover <agrover@redhat.com>2015-04-23 10:07:58 -0700
commit6dfe057b79602e76b1cfc311ee9226ab68e5c70e (patch)
tree0a6be904f02ae814ecfe014582317ca287459e2f
parent2ce51579fe31a2eef909e2b8a7aac4da39cc03a6 (diff)
downloadrtslib-fb-fix-pkgbuild.tar.gz
Try to adapt Makefile to new pkgbuild file locationfix-pkgbuild
Haven't tested 'make deb, but 'make rpm' sure doesn't work. A little help?
-rw-r--r--Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index f975c6e..4a6752f 100644
--- a/Makefile
+++ b/Makefile
@@ -40,7 +40,7 @@ clean:
@rm -frv debian/${PKGNAME}-doc/ debian/python2.5-${PKGNAME}/
@rm -frv debian/python2.6-${PKGNAME}/ debian/python-${PKGNAME}/
@rm -frv results
- @rm -fv rpm/*.spec *.spec rpm/sed* sed*
+ @rm -fv example/rpm/*.spec *.spec example/rpm/sed* sed*
@rm -frv ${PKGNAME}-*
@echo "Finished cleanup."
@@ -61,11 +61,11 @@ build/release-stamp:
build/${PKGNAME}-${VERSION}/${NAME}/__init__.py
@echo "Generating rpm specfile from template..."
@cd build/${PKGNAME}-${VERSION}; \
- for spectmpl in rpm/*.spec.tmpl; do \
+ for spectmpl in example/rpm/*.spec.tmpl; do \
sed -i "s/Version:\( *\).*/Version:\1${VERSION}/g" $${spectmpl}; \
mv $${spectmpl} $$(basename $${spectmpl} .tmpl); \
done; \
- rm -r rpm
+ rm -r example/rpm
@echo "Generating rpm changelog..."
@( \
version=$$(basename $$(git describe HEAD --tags | tr - .)); \
@@ -93,7 +93,7 @@ build/release-stamp:
echo; \
echo " -- $${author} $${date}"; \
echo; \
- ) > build/${PKGNAME}-${VERSION}/debian/changelog
+ ) > build/${PKGNAME}-${VERSION}/example/debian/changelog
@find build/${PKGNAME}-${VERSION}/ -exec \
touch -t $$(date -d @$$(git show -s --format="format:%at") \
+"%Y%m%d%H%M.%S") {} \;