summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Mueller <dirk@dmllr.de>2016-11-03 22:35:29 +0100
committerDirk Mueller <dirk@dmllr.de>2016-11-03 22:35:29 +0100
commit925281b9f036552f7fe252da0e05407f4ed2db62 (patch)
treeaabc7e4355bd4e0b9a16033e3550d954ad801fc9
parent1c2730e9913ae859e3de3ce74c6dc4ad661d489c (diff)
downloadrtslib-fb-925281b9f036552f7fe252da0e05407f4ed2db62.tar.gz
Depend on pyudev during runtime
In v2.1.fb60 an unconditional dependency to pyudev was added, which needs to be specified in the egg info, otherwise pip install might fail with e.g. File "local/lib/python2.7/site-packages/rtslib/utils.py", line 30, in <module> import pyudev ImportError: No module named pyudev
-rwxr-xr-xsetup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 48f6282..7770032 100755
--- a/setup.py
+++ b/setup.py
@@ -28,6 +28,7 @@ setup (
url = 'http://github.com/open-iscsi/rtslib-fb',
packages = ['rtslib_fb', 'rtslib'],
scripts = ['scripts/targetctl'],
+ install_requires = ['pyudev >= 0.16.1'],
classifiers = [
"Programming Language :: Python",
"Programming Language :: Python :: 3",