summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJared Hulbert <jaredeh@gmail.com>2016-06-21 16:02:14 -0700
committerJared Hulbert <jaredeh@gmail.com>2016-06-21 16:02:14 -0700
commit95754007b2e1cbf7b65f8472c69b30d72ceffe2a (patch)
tree2a4c6046f8ae8eac19b6335b2e76b2e9644fffd8
parentdda8dc71b59d3fa2abe7e63d1e67581067e9a241 (diff)
downloadrtslib-fb-95754007b2e1cbf7b65f8472c69b30d72ceffe2a.tar.gz
fixes to debian package scripts
-rw-r--r--example-debian/control2
-rwxr-xr-xexample-debian/rules4
2 files changed, 3 insertions, 3 deletions
diff --git a/example-debian/control b/example-debian/control
index 86ddfc2..0c831db 100644
--- a/example-debian/control
+++ b/example-debian/control
@@ -2,7 +2,7 @@ Source: rtslib-fb
Section: python
Priority: optional
Maintainer: Andy Grover <andy@groveronline.com>
-Build-Depends: debhelper(>= 8), python, python3 , python-epydoc, python-setuptools, python3-setuptools
+Build-Depends: debhelper(>= 8), python, python3 , python-epydoc, python-setuptools, python3-setuptools, python-six, python-pyudev, dh-python
Standards-Version: 3.9.4
X-Python-Version: >= 2.6
X-Python3-Version: >= 3.1
diff --git a/example-debian/rules b/example-debian/rules
index 6250ceb..3eae1a1 100755
--- a/example-debian/rules
+++ b/example-debian/rules
@@ -21,7 +21,7 @@ export http_proxy = http://127.0.0.1:9
build-python%:
python$* setup.py build
-override_dh_auto_build: $(PYTHON3:%=build-python%)
+override_dh_auto_build: $(PYTHON3:%=build-python%) $(PYTHON2:%=build-python%)
dh_auto_build
@@ -29,7 +29,7 @@ install-python%:
python$* setup.py install --root=$(install_dir) --install-layout=deb
-override_dh_auto_install: $(PYTHON3:%=install-python%)
+override_dh_auto_install: $(PYTHON3:%=install-python%) $(PYTHON2:%=install-python%)
dh_auto_install
# for using python 3 for targetctl
# even though it is overwritten by python2 setup