summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNayef Ghattas <nayef.ghatas@gmail.com>2016-06-13 23:19:22 +0200
committerNayef Ghattas <nayef.ghatas@gmail.com>2016-06-13 23:19:22 +0200
commitcf92f069fe5786a4caf1655933d6a3791f1ed176 (patch)
tree5b842d5c67369c73ea4c1dedd4c7874ffeb5cc64
parenta2f4165010eec2e5b9aee09dc1bd0ddecfd6dd33 (diff)
downloadrtslib-fb-cf92f069fe5786a4caf1655933d6a3791f1ed176.tar.gz
Changed example-debian folder for compatibility with dpkg-buildpackage
-rw-r--r--Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index bfc9010..8716fe2 100644
--- a/Makefile
+++ b/Makefile
@@ -66,6 +66,7 @@ build/release-stamp:
mv $${spectmpl} $$(basename $${spectmpl} .tmpl); \
done; \
rm -r example-rpm
+ @mv build/${PKGNAME}-${VERSION}/example-debian build/${PKGNAME}-${VERSION}/debian
@echo "Generating rpm changelog..."
@( \
version=$$(basename $$(git describe HEAD --tags | tr - .)); \
@@ -93,7 +94,7 @@ build/release-stamp:
echo; \
echo " -- $${author} $${date}"; \
echo; \
- ) > build/${PKGNAME}-${VERSION}/example-debian/changelog
+ ) > build/${PKGNAME}-${VERSION}/debian/changelog
@find build/${PKGNAME}-${VERSION}/ -exec \
touch -t $$(date -d @$$(git show -s --format="format:%at") \
+"%Y%m%d%H%M.%S") {} \;