summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAnthon van der Neut <anthon@mnt.org>2015-01-14 21:02:09 +0100
committerAnthon van der Neut <anthon@mnt.org>2015-01-14 21:02:09 +0100
commit50dae579992b7f92750d1704bc2f1019543dd227 (patch)
tree9570d2c8c8c0ab8695fd8b0d278a740ae8ead647 /setup.py
parent680b278b1da87bd5bd6ef5c84f24e59f9a7ed23a (diff)
downloadruamel.std.argparse-50dae579992b7f92750d1704bc2f1019543dd227.tar.gz
- update failing test on py26
- now dependent on ruamel.base for creating ruamel/std/__init__.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 98a8b38..9d488cd 100644
--- a/setup.py
+++ b/setup.py
@@ -75,7 +75,7 @@ class MyInstallLib(install_lib.install_lib):
"create __init__.py on the fly"
def run(self):
install_lib.install_lib.run(self)
- init_txt = dedent('''\
+ init_txt = dedent('''\y
# coding: utf-8
# Copyright © 2013-2014 Anthon van der Neut, RUAMEL bvba
"generated __init__.py "
@@ -91,6 +91,7 @@ class MyInstallLib(install_lib.install_lib):
for p in range(len(init_path))
]:
if not os.path.exists(product_init):
+ raise NotImplementedError
print('creating %s' % product_init)
with open(product_init, "w") as fp:
fp.write(init_txt)
@@ -117,6 +118,7 @@ class MyInstallLib(install_lib.install_lib):
def main():
install_requires = [
+ "ruamel.base",
]
if sys.version_info[:2] == (2, 6):
install_requires.append("argparse")