summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthon van der Neut <anthon@mnt.org>2019-07-12 08:01:59 +0200
committerAnthon van der Neut <anthon@mnt.org>2019-07-12 08:01:59 +0200
commit1a6f9f94ed7e2322f75cf1d4ca15254205c8a856 (patch)
tree141e267c58c61437212dfabb5dac160800d2f2c8
parent745311fad7d45c0721cf4ed1903b56057939726a (diff)
downloadruamel.yaml-0.15.99.tar.gz
add py.typed to distribution0.15.99
-rw-r--r--CHANGES16
-rw-r--r--README.rst12
-rw-r--r--__init__.py5
-rw-r--r--_doc/_static/pypi.svg2
-rw-r--r--docker-compose.yaml (renamed from docker-compose.yml)0
-rw-r--r--py.typed0
-rw-r--r--setup.py10
7 files changed, 40 insertions, 5 deletions
diff --git a/CHANGES b/CHANGES
index 76621c2..24a099b 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,3 +1,19 @@
+[0, 15, 99]: 2019-07-12
+ - add `py.typed` to distribution, based on a PR submitted by
+ `Michael Crusoe
+ <https://bitbucket.org/%7Bc9fbde69-e746-48f5-900d-34992b7860c8%7D/>`__
+ - merge PR 40 (also by Michael Crusoe) to more accurately specify
+ repository in the README (also reported in a misunderstood issue
+ some time ago)
+
+[0, 15, 99]: 2019-07-12
+ - add `py.typed` to distribution, based on a PR submitted by
+ `Michael Crusoe
+ <https://bitbucket.org/%7Bc9fbde69-e746-48f5-900d-34992b7860c8%7D/>`__
+ - merge PR 40 (also by Michael Crusoe) to more accurately specify
+ repository in the README (also reported in a misunderstood issue
+ some time ago)
+
[0, 15, 98]: 2019-07-09
- regenerate ext/_ruamel_yaml.c with Cython version 0.29.12, needed
for Python 3.8.0b2 (reported by `John Vandenberg
diff --git a/README.rst b/README.rst
index 0d739ee..bc7c83c 100644
--- a/README.rst
+++ b/README.rst
@@ -4,8 +4,8 @@ ruamel.yaml
``ruamel.yaml`` is a YAML 1.2 loader/dumper package for Python.
-:version: 0.15.98
-:updated: 2019-07-09
+:version: 0.15.99
+:updated: 2019-07-12
:documentation: http://yaml.readthedocs.io
:repository: https://bitbucket.org/ruamel/yaml
:pypi: https://pypi.org/project/ruamel.yaml/
@@ -54,6 +54,14 @@ ChangeLog
.. should insert NEXT: at the beginning of line for next key (with empty line)
+0.15.99 (2019-07-12):
+ - add `py.typed` to distribution, based on a PR submitted by
+ `Michael Crusoe
+ <https://bitbucket.org/%7Bc9fbde69-e746-48f5-900d-34992b7860c8%7D/>`__
+ - merge PR 40 (also by Michael Crusoe) to more accurately specify
+ repository in the README (also reported in a misunderstood issue
+ some time ago)
+
0.15.98 (2019-07-09):
- regenerate ext/_ruamel_yaml.c with Cython version 0.29.12, needed
for Python 3.8.0b2 (reported by `John Vandenberg
diff --git a/__init__.py b/__init__.py
index c066b3f..07827ed 100644
--- a/__init__.py
+++ b/__init__.py
@@ -7,8 +7,8 @@ if False: # MYPY
_package_data = dict(
full_package_name='ruamel.yaml',
- version_info=(0, 15, 98),
- __version__='0.15.98',
+ version_info=(0, 15, 99),
+ __version__='0.15.99',
author='Anthon van der Neut',
author_email='a.van.der.neut@ruamel.eu',
description='ruamel.yaml is a YAML parser/emitter that supports roundtrip preservation of comments, seq/map flow style, and map key order', # NOQA
@@ -53,6 +53,7 @@ _package_data = dict(
'Programming Language :: Python :: Implementation :: Jython',
'Topic :: Software Development :: Libraries :: Python Modules',
'Topic :: Text Processing :: Markup',
+ 'Typing :: Typed',
],
keywords='yaml 1.2 parser round-trip preserve quotes order config',
wheels=dict(
diff --git a/_doc/_static/pypi.svg b/_doc/_static/pypi.svg
index eb068dc..0d4493b 100644
--- a/_doc/_static/pypi.svg
+++ b/_doc/_static/pypi.svg
@@ -1 +1 @@
-<svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="86" height="20"><linearGradient id="b" x2="0" y2="100%"><stop offset="0" stop-color="#bbb" stop-opacity=".1"/><stop offset="1" stop-opacity=".1"/></linearGradient><clipPath id="a"><rect width="86" height="20" rx="3" fill="#fff"/></clipPath><g clip-path="url(#a)"><path fill="#555" d="M0 0h33v20H0z"/><path fill="#007ec6" d="M33 0h53v20H33z"/><path fill="url(#b)" d="M0 0h86v20H0z"/></g><g fill="#fff" text-anchor="middle" font-family="DejaVu Sans,Verdana,Geneva,sans-serif" font-size="110"> <text x="175" y="150" fill="#010101" fill-opacity=".3" transform="scale(.1)" textLength="230">pypi</text><text x="175" y="140" transform="scale(.1)" textLength="230">pypi</text><text x="585" y="150" fill="#010101" fill-opacity=".3" transform="scale(.1)" textLength="430">0.15.98</text><text x="585" y="140" transform="scale(.1)" textLength="430">0.15.98</text></g> </svg>
+<svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="86" height="20"><linearGradient id="b" x2="0" y2="100%"><stop offset="0" stop-color="#bbb" stop-opacity=".1"/><stop offset="1" stop-opacity=".1"/></linearGradient><clipPath id="a"><rect width="86" height="20" rx="3" fill="#fff"/></clipPath><g clip-path="url(#a)"><path fill="#555" d="M0 0h33v20H0z"/><path fill="#007ec6" d="M33 0h53v20H33z"/><path fill="url(#b)" d="M0 0h86v20H0z"/></g><g fill="#fff" text-anchor="middle" font-family="DejaVu Sans,Verdana,Geneva,sans-serif" font-size="110"> <text x="175" y="150" fill="#010101" fill-opacity=".3" transform="scale(.1)" textLength="230">pypi</text><text x="175" y="140" transform="scale(.1)" textLength="230">pypi</text><text x="585" y="150" fill="#010101" fill-opacity=".3" transform="scale(.1)" textLength="430">0.15.99</text><text x="585" y="140" transform="scale(.1)" textLength="430">0.15.99</text></g> </svg>
diff --git a/docker-compose.yml b/docker-compose.yaml
index be63d4a..be63d4a 100644
--- a/docker-compose.yml
+++ b/docker-compose.yaml
diff --git a/py.typed b/py.typed
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/py.typed
diff --git a/setup.py b/setup.py
index 9b15f4e..5d9dc9e 100644
--- a/setup.py
+++ b/setup.py
@@ -656,6 +656,12 @@ class NameSpacePackager(object):
and only adding defaults when no explicit entries were provided.
Add explicit Python versions in sync with tox.env generation based on python_requires?
"""
+ attr = '_' + sys._getframe().f_code.co_name
+ if not hasattr(self, attr):
+ setattr(self, attr, self._setup_classifiers())
+ return getattr(self, attr)
+
+ def _setup_classifiers(self):
return sorted(
set(
[
@@ -760,6 +766,10 @@ class NameSpacePackager(object):
df.append('LICENSE')
# but don't install it
exclude_files.append('LICENSE')
+ debug('testing<<<<<')
+ if 'Typing :: Typed' in self.classifiers:
+ debug('appending')
+ df.append('py.typed')
pd = self._pkg_data.get('package_data', {})
if df:
pd[self.full_package_name] = df