summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthon van der Neut <anthon@mnt.org>2020-02-12 13:32:08 +0100
committerAnthon van der Neut <anthon@mnt.org>2020-02-12 13:32:08 +0100
commit0bba498f9cbbd6b0a31061520e7505d52e6ef029 (patch)
treead92eb8b2d420d05a85cd18e7566c6ee7cc56222
parent7864c7dc54ad566bbcdb968da88f03c0f3e57d5b (diff)
downloadruamel.yaml-0.16.10.tar.gz
update url in meta and .svg in README0.16.10
-rw-r--r--CHANGES3
-rw-r--r--README.rst12
-rw-r--r--__init__.py7
-rw-r--r--_doc/_static/pypi.svg2
-rw-r--r--setup.py16
-rwxr-xr-xtox.ini5
6 files changed, 25 insertions, 20 deletions
diff --git a/CHANGES b/CHANGES
index 61bb167..a70a8ef 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,3 +1,6 @@
+[0, 16, 10]: 2020-02-12
+ - (auto) updated image references in README to sourceforge
+
[0, 16, 9]: 2020-02-11
- update CHANGES
diff --git a/README.rst b/README.rst
index 8384755..2a99cb9 100644
--- a/README.rst
+++ b/README.rst
@@ -4,8 +4,8 @@ ruamel.yaml
``ruamel.yaml`` is a YAML 1.2 loader/dumper package for Python.
-:version: 0.16.9
-:updated: 2020-02-11
+:version: 0.16.10
+:updated: 2020-02-12
:documentation: http://yaml.readthedocs.io
:repository: https://bitbucket.org/ruamel/yaml
:pypi: https://pypi.org/project/ruamel.yaml/
@@ -37,13 +37,13 @@ when the status of the API is stable enough to make the transition.
.. image:: https://bestpractices.coreinfrastructure.org/projects/1128/badge
:target: https://bestpractices.coreinfrastructure.org/projects/1128
-.. image:: https://bitbucket.org/ruamel/yaml/raw/default/_doc/_static/license.svg
+.. image:: https://sourceforge.net/p/ruamel-yaml/code/ci/default/tree/_doc/_static/license.svg?format=raw
:target: https://opensource.org/licenses/MIT
-.. image:: https://bitbucket.org/ruamel/yaml/raw/default/_doc/_static/pypi.svg
+.. image:: https://sourceforge.net/p/ruamel-yaml/code/ci/default/tree/_doc/_static/pypi.svg?format=raw
:target: https://pypi.org/project/ruamel.yaml/
-.. image:: https://bitbucket.org/ruamel/oitnb/raw/default/_doc/_static/oitnb.svg
+.. image:: https://sourceforge.net/p/oitnb/code/ci/default/tree/_doc/_static/oitnb.svg?format=raw
:target: https://pypi.org/project/oitnb/
.. image:: http://www.mypy-lang.org/static/mypy_badge.svg
@@ -54,6 +54,8 @@ ChangeLog
.. should insert NEXT: at the beginning of line for next key (with empty line)
+0.16.10 (2020-02-12):
+ - (auto) updated image references in README to sourceforge
0.16.9 (2020-02-11):
- update CHANGES
diff --git a/__init__.py b/__init__.py
index 940cb6b..7bc157b 100644
--- a/__init__.py
+++ b/__init__.py
@@ -7,8 +7,8 @@ if False: # MYPY
_package_data = dict(
full_package_name='ruamel.yaml',
- version_info=(0, 16, 9),
- __version__='0.16.9',
+ version_info=(0, 16, 10),
+ __version__='0.16.10',
author='Anthon van der Neut',
author_email='a.van.der.neut@ruamel.eu',
description='ruamel.yaml is a YAML parser/emitter that supports roundtrip preservation of comments, seq/map flow style, and map key order', # NOQA
@@ -26,6 +26,7 @@ _package_data = dict(
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Programming Language :: Python :: Implementation :: Jython',
@@ -37,7 +38,7 @@ _package_data = dict(
read_the_docs='yaml',
supported=[(2, 7), (3, 5)], # minimum
tox=dict(
- env='*pn', # also test narrow Python 2.7.15 for unicode patterns
+ env='*', # remove 'pn', no longer test narrow Python 2.7 for unicode patterns and PyPy
deps='ruamel.std.pathlib',
fl8excl='_test/lib',
),
diff --git a/_doc/_static/pypi.svg b/_doc/_static/pypi.svg
index 92e32c6..15d64e3 100644
--- a/_doc/_static/pypi.svg
+++ b/_doc/_static/pypi.svg
@@ -1 +1 @@
-<svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="86" height="20"><linearGradient id="b" x2="0" y2="100%"><stop offset="0" stop-color="#bbb" stop-opacity=".1"/><stop offset="1" stop-opacity=".1"/></linearGradient><clipPath id="a"><rect width="86" height="20" rx="3" fill="#fff"/></clipPath><g clip-path="url(#a)"><path fill="#555" d="M0 0h33v20H0z"/><path fill="#007ec6" d="M33 0h53v20H33z"/><path fill="url(#b)" d="M0 0h86v20H0z"/></g><g fill="#fff" text-anchor="middle" font-family="DejaVu Sans,Verdana,Geneva,sans-serif" font-size="110"> <text x="175" y="150" fill="#010101" fill-opacity=".3" transform="scale(.1)" textLength="230">pypi</text><text x="175" y="140" transform="scale(.1)" textLength="230">pypi</text><text x="585" y="150" fill="#010101" fill-opacity=".3" transform="scale(.1)" textLength="430">0.16.9</text><text x="585" y="140" transform="scale(.1)" textLength="430">0.16.9</text></g> </svg>
+<svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="86" height="20"><linearGradient id="b" x2="0" y2="100%"><stop offset="0" stop-color="#bbb" stop-opacity=".1"/><stop offset="1" stop-opacity=".1"/></linearGradient><clipPath id="a"><rect width="86" height="20" rx="3" fill="#fff"/></clipPath><g clip-path="url(#a)"><path fill="#555" d="M0 0h33v20H0z"/><path fill="#007ec6" d="M33 0h53v20H33z"/><path fill="url(#b)" d="M0 0h86v20H0z"/></g><g fill="#fff" text-anchor="middle" font-family="DejaVu Sans,Verdana,Geneva,sans-serif" font-size="110"> <text x="175" y="150" fill="#010101" fill-opacity=".3" transform="scale(.1)" textLength="230">pypi</text><text x="175" y="140" transform="scale(.1)" textLength="230">pypi</text><text x="585" y="150" fill="#010101" fill-opacity=".3" transform="scale(.1)" textLength="430">0.16.10</text><text x="585" y="140" transform="scale(.1)" textLength="430">0.16.10</text></g> </svg>
diff --git a/setup.py b/setup.py
index 1cc1a5a..f22dceb 100644
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,6 @@
# # header
# coding: utf-8
-# dd: 20190815
+# dd: 20200125
from __future__ import print_function, absolute_import, division, unicode_literals
@@ -51,7 +51,6 @@ if sys.version_info < (3, 4):
if sys.version_info >= (3, 8):
-
from ast import Str, Num, Bytes, NameConstant # NOQA
@@ -540,11 +539,13 @@ class NameSpacePackager(object):
@property
def url(self):
- if self.full_package_name.startswith('ruamel.'):
- sp = self.full_package_name.split('.', 1)
- else:
- sp = ['ruamel', self.full_package_name]
- return 'https://bitbucket.org/{0}/{1}'.format(*sp)
+ url = self._pkg_data.get('url')
+ if url:
+ return url
+ sp = self.full_package_name
+ for ch in '_.':
+ sp = sp.replace(ch, '-')
+ return 'https://sourceforge.net/p/{0}/code/ci/default/tree'.format(sp)
@property
def author(self):
@@ -927,6 +928,7 @@ def main():
try:
with open('README.rst') as fp:
kw['long_description'] = fp.read()
+ kw['long_description_content_type'] = 'text/x-rst'
except Exception:
pass
diff --git a/tox.ini b/tox.ini
index c1c3644..0e5fb67 100755
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
# toxworkdir = /data1/DATA/tox/ruamel.yaml
-envlist = cs,py37,py27,py36,py35,py38,py39,pypy,py27m
+envlist = cs,py38,py27,py37,py36,py35,py39
[testenv]
commands =
@@ -9,9 +9,6 @@ deps =
pytest
ruamel.std.pathlib
-[testenv:py27m]
-basepython = /opt/python/2.7.15m/bin/python
-
[testenv:cs]
basepython = python3.6
deps =