summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthon van der Neut <anthon@mnt.org>2017-06-15 18:18:49 +0200
committerAnthon van der Neut <anthon@mnt.org>2017-06-15 18:18:49 +0200
commitcb05728331c475c17eae8b86a1fc0848b7a2872f (patch)
tree7303ef0b08303f3d5e079974dea9fb5786554787
parent5a768e5d582a563f58f3eebd479a4b1d564feff4 (diff)
downloadruamel.yaml-cb05728331c475c17eae8b86a1fc0848b7a2872f.tar.gz
enable: pip install ruamel.yaml[jinja2]0.15.8
-rw-r--r--.hgignore1
-rw-r--r--CHANGES3
-rw-r--r--LICENSE12
-rw-r--r--Makefile56
-rw-r--r--README.rst3
-rw-r--r--__init__.py6
l---------setup.py1
-rw-r--r--tox.ini11
8 files changed, 23 insertions, 70 deletions
diff --git a/.hgignore b/.hgignore
index 4cf5804..0a6f71f 100644
--- a/.hgignore
+++ b/.hgignore
@@ -14,7 +14,6 @@ syntax: glob
dist
build
*.egg-info
-setup.py
# tox related
.tox
.cache
diff --git a/CHANGES b/CHANGES
index 9ef21b7..64d1e22 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,3 +1,6 @@
+[0, 15, 8]: 2017-06-15
+ - allow plug-in install via ``install ruamel.yaml[jinja2]``
+
[0, 15, 7]: 2017-06-14
- add plug-in mechanism for load/dump pre resp. post-processing
diff --git a/LICENSE b/LICENSE
index f6f753a..aacc976 100644
--- a/LICENSE
+++ b/LICENSE
@@ -1,21 +1,21 @@
-
The MIT License (MIT)
+ Copyright (c) 2014-2017 Anthon van der Neut, Ruamel bvba
+
Permission is hereby granted, free of charge, to any person obtaining a copy
of this software and associated documentation files (the "Software"), to deal
in the Software without restriction, including without limitation the rights
to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
copies of the Software, and to permit persons to whom the Software is
furnished to do so, subject to the following conditions:
-
+
The above copyright notice and this permission notice shall be included in
all copies or substantial portions of the Software.
-
+
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
- OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
- THE SOFTWARE.
-
+ OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+ SOFTWARE.
diff --git a/Makefile b/Makefile
index e5b28f6..d38502f 100644
--- a/Makefile
+++ b/Makefile
@@ -1,57 +1,9 @@
UTILNAME:=yaml
PKGNAME:=ruamel.yaml
-VERSION:=$(shell python setup.py --version)
-REGEN:=/home/bin/ruamel_util_new util --published --command YAML --skip-hg
+INSTPKGNAME:=--pkg ruamel.yaml
+VERSION:=0.15.8.dev
-include ~/.config/ruamel_util_new/Makefile.inc
+include ~/.config/develop/Makefile.inc
-gen_win_whl:
- python2 setup.py bdist_wheel --plat-name win32
- python2 setup.py bdist_wheel --plat-name win_amd64
- python3 setup.py bdist_wheel --plat-name win32
- python3 setup.py bdist_wheel --plat-name win_amd64
- # @python make_win_whl.py dist/$(PKGNAME)-$(VERSION)-*-none-any.whl
-
-clean: clean_common
- find . -name "*py.class" -exec rm {} +
-
-cython: ext/_yaml.c
-
-ext/_yaml.c: ext/_yaml.pyx
- cd ext; cython _yaml.pyx
-
-ls-l:
- ls -l dist/*$(VERSION)*
-
-pytest:
- py.test _test/*.py
-
-MYPYSRC:=$(shell ls -1 *.py | grep -Ev "^(setup.py|.*_flymake.py)$$" | sed 's|^|ruamel/yaml/|')
-MYPYOPT:=--py2 --strict
-
-mypy: mypy2single
-
-mypyold:
- cd ..; mypy --strict --no-warn-unused-ignores yaml/*.py
-
-# sleep to give time to flymake*.py to disappear
-mypy2:
- cd ../.. ; mypy $(MYPYOPT) $(MYPYSRC)
-
-mypy2single:
- @echo 'mypy *.py'
- @cd ../.. ; mypy $(MYPYOPT) $(MYPYSRC) | fgrep -v ordereddict/__init | grep .
-# @echo 'mypy ' $(MYPYSRC)
-
-#tstvenv: testvenv testsetup testtest
-#
-#testvenv:
-# virtualenv -p /opt/python/2.7/bin/python testvenv
-#
-#testsetup:
-# testvenv/bin/pip install -e .
-# testvenv/bin/pip install pytest
-#
-#testtest:
-# testvenv/bin/py.test
+clean: clean_common
diff --git a/README.rst b/README.rst
index fa503a9..29c2ad4 100644
--- a/README.rst
+++ b/README.rst
@@ -32,6 +32,9 @@ ChangeLog
.. should insert NEXT: at the beginning of line for next key
+0.15.8 (2017-06-15):
+ - allow plug-in install via ``install ruamel.yaml[jinja2]``
+
0.15.7 (2017-06-14):
- add plug-in mechanism for load/dump pre resp. post-processing
diff --git a/__init__.py b/__init__.py
index ba29709..48f5fbe 100644
--- a/__init__.py
+++ b/__init__.py
@@ -11,8 +11,8 @@ if False: # MYPY
_package_data = dict(
full_package_name='ruamel.yaml',
- version_info=(0, 15, 7),
- __version__='0.15.7',
+ version_info=(0, 15, 8),
+ __version__='0.15.8',
author='Anthon van der Neut',
author_email='a.van.der.neut@ruamel.eu',
description='ruamel.yaml is a YAML parser/emitter that supports roundtrip preservation of comments, seq/map flow style, and map key order', # NOQA
@@ -20,7 +20,7 @@ _package_data = dict(
since=2014,
extras_require={':platform_python_implementation=="CPython" and python_version<="2.7"': [
'ruamel.ordereddict',
- ]},
+ ], 'jinja2': ['ruamel.yaml.jinja2']},
ext_modules=[dict(
name='_ruamel_yaml',
src=['ext/_ruamel_yaml.c', 'ext/api.c', 'ext/writer.c', 'ext/dumper.c',
diff --git a/setup.py b/setup.py
new file mode 120000
index 0000000..3f639c9
--- /dev/null
+++ b/setup.py
@@ -0,0 +1 @@
+/home/anthon/.config/develop/setup.py \ No newline at end of file
diff --git a/tox.ini b/tox.ini
index 0fcce23..629205d 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,24 +1,19 @@
[tox]
-# envlist = pep8,py35,py27,py34,py33,py26,pypy,jython
-#envlist = py35,py27,py34,py33,py26,pypy,jython
envlist = pep8,py36,py27,py35,py34,pypy
[testenv]
commands =
- /bin/bash -c 'py.test _test/test_*.py'
+ /bin/bash -c 'pytest _test/test_*.py'
deps =
pytest
flake8==2.5.5
ruamel.std.pathlib
-[pytest]
-norecursedirs = test/lib .tox
-
[testenv:pep8]
commands =
- flake8 --exclude convert,cmd,base {posargs}
+ flake8 {posargs}
[flake8]
show-source = True
max-line-length = 95
-exclude = _test/lib,.hg,.git,.tox,dist,.cache,__pycache__,ruamel.zip2tar.egg-info,try_*
+exclude = _test/lib,.hg,.git,.tox,dist,.cache,__pycache__,ruamel.zip2tar.egg-info