summaryrefslogtreecommitdiff
path: root/_doc
diff options
context:
space:
mode:
authorAnthon van der Neut <anthon@mnt.org>2019-04-16 08:46:25 +0200
committerAnthon van der Neut <anthon@mnt.org>2019-04-16 08:46:25 +0200
commite0a5db9c8b1df89db6ee0195cb9e304eee34b7ed (patch)
treeeb59e8cdd66a1ca8869f508f5ba9a0eda4e554dd /_doc
parentf26a259a769edcf9a62233ea3c605c92dc3c8073 (diff)
downloadruamel.yaml-e0a5db9c8b1df89db6ee0195cb9e304eee34b7ed.tar.gz
YAML 1.2 allows empty implicit keys in block style mappings0.15.92
fixes issue #284 *When this change indeed resolves your problem, please **Close** this issue*. *(You can do so using the WorkFlow pull-down (close to the top right of this page))*
Diffstat (limited to '_doc')
-rw-r--r--_doc/Makefile2
-rw-r--r--_doc/_static/pypi.svg2
-rw-r--r--_doc/api.ryd4
-rw-r--r--_doc/conf.py34
4 files changed, 24 insertions, 18 deletions
diff --git a/_doc/Makefile b/_doc/Makefile
index 630532d..c5d1aa0 100644
--- a/_doc/Makefile
+++ b/_doc/Makefile
@@ -4,7 +4,7 @@
# You can set these variables from the command line.
SPHINXOPTS =
SPHINXBUILD = sphinx-build
-PAPER =
+PAPER = a4
BUILDDIR = _build
# User-friendly check for sphinx-build
diff --git a/_doc/_static/pypi.svg b/_doc/_static/pypi.svg
index 6bc0f5e..d1ffe22 100644
--- a/_doc/_static/pypi.svg
+++ b/_doc/_static/pypi.svg
@@ -1 +1 @@
-<svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="86" height="20"><linearGradient id="b" x2="0" y2="100%"><stop offset="0" stop-color="#bbb" stop-opacity=".1"/><stop offset="1" stop-opacity=".1"/></linearGradient><clipPath id="a"><rect width="86" height="20" rx="3" fill="#fff"/></clipPath><g clip-path="url(#a)"><path fill="#555" d="M0 0h33v20H0z"/><path fill="#007ec6" d="M33 0h53v20H33z"/><path fill="url(#b)" d="M0 0h86v20H0z"/></g><g fill="#fff" text-anchor="middle" font-family="DejaVu Sans,Verdana,Geneva,sans-serif" font-size="110"> <text x="175" y="150" fill="#010101" fill-opacity=".3" transform="scale(.1)" textLength="230">pypi</text><text x="175" y="140" transform="scale(.1)" textLength="230">pypi</text><text x="585" y="150" fill="#010101" fill-opacity=".3" transform="scale(.1)" textLength="430">0.15.91</text><text x="585" y="140" transform="scale(.1)" textLength="430">0.15.91</text></g> </svg>
+<svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="86" height="20"><linearGradient id="b" x2="0" y2="100%"><stop offset="0" stop-color="#bbb" stop-opacity=".1"/><stop offset="1" stop-opacity=".1"/></linearGradient><clipPath id="a"><rect width="86" height="20" rx="3" fill="#fff"/></clipPath><g clip-path="url(#a)"><path fill="#555" d="M0 0h33v20H0z"/><path fill="#007ec6" d="M33 0h53v20H33z"/><path fill="url(#b)" d="M0 0h86v20H0z"/></g><g fill="#fff" text-anchor="middle" font-family="DejaVu Sans,Verdana,Geneva,sans-serif" font-size="110"> <text x="175" y="150" fill="#010101" fill-opacity=".3" transform="scale(.1)" textLength="230">pypi</text><text x="175" y="140" transform="scale(.1)" textLength="230">pypi</text><text x="585" y="150" fill="#010101" fill-opacity=".3" transform="scale(.1)" textLength="430">0.15.92</text><text x="585" y="140" transform="scale(.1)" textLength="430">0.15.92</text></g> </svg>
diff --git a/_doc/api.ryd b/_doc/api.ryd
index a295565..314bfbd 100644
--- a/_doc/api.ryd
+++ b/_doc/api.ryd
@@ -95,7 +95,7 @@ all functionality of the old interface will be available via
``YAML`` instances (if you are using something that isn't let me know).
If a parse or dump fails, and throws and exception, the state of the
-`YAML()` instance is not guaranteed to be able to handle further
+``YAML()`` instance is not guaranteed to be able to handle further
processing. You should, at that point to recreate the YAML instance before
proceeding.
@@ -158,7 +158,7 @@ works for output (dumping) only, requires you to specify the output
Within the context manager, you cannot use the ``dump()`` with a
second (stream) argument, nor can you use ``dump_all()``. The
``dump()`` within the context of the ``YAML()`` automatically creates
- multi-document if called more than once.
+multi-document if called more than once.
To combine multiple YAML documents from multiple files:
diff --git a/_doc/conf.py b/_doc/conf.py
index f0fbcad..610eecb 100644
--- a/_doc/conf.py
+++ b/_doc/conf.py
@@ -36,7 +36,7 @@ templates_path = ['_templates']
# The suffix(es) of source filenames.
# You can specify multiple suffix as a list of string:
# source_suffix = ['.rst', '.md']
-source_suffix = '.rst'
+source_suffix = {'.rst': 'restructuredtext', '.ryd': 'ryd2rst'}
# The encoding of source files.
# source_encoding = 'utf-8-sig'
@@ -46,7 +46,7 @@ master_doc = 'index'
# General information about the project.
project = u'yaml'
-copyright = u'2017-2018, Anthon van der Neut, Ruamel bvba'
+copyright = u'2017-2019, Anthon van der Neut, Ruamel bvba'
author = u'Anthon van der Neut'
# The version info for the project you're documenting, acts as replacement for
@@ -67,20 +67,26 @@ print('ruamel.yaml version', version)
# print('cwd:', os.getcwd())
# current working directory is the one with `conf.py` !
-try:
- from ryd.__main__ import RYDCmd
- from ruamel.std.pathlib import Path
- oldargv = sys.argv
- for fn in Path('.').glob('*.ryd'):
- sys.argv = ['ryd', 'convert', '--no-pdf', str(fn)]
- rc = RYDCmd()
- rc.parse_args()
- print(sys.argv, '->', rc.run())
- sys.argv = oldargv
+class ryd2rst:
+ pass
-except Exception as e:
- print('ryd exception', e)
+
+if False:
+ try:
+ from ryd.__main__ import RYDCmd
+ from ruamel.std.pathlib import Path
+
+ oldargv = sys.argv
+ for fn in Path('.').glob('*.ryd'):
+ sys.argv = ['ryd', 'convert', '--no-pdf', str(fn)]
+ rc = RYDCmd()
+ rc.parse_args()
+ print(sys.argv, '->', rc.run())
+ sys.argv = oldargv
+
+ except Exception as e:
+ print('ryd exception', e)
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.