summaryrefslogtreecommitdiff
path: root/emitter.py
diff options
context:
space:
mode:
authorAnthon van der Neut <anthon@mnt.org>2020-09-03 20:40:51 +0200
committerAnthon van der Neut <anthon@mnt.org>2020-09-03 20:40:51 +0200
commit53a39bcc144e46221caee39f49cd753f956b0657 (patch)
treeb45181ad4864f66157be031648da1bfa2e4baab5 /emitter.py
parentb3acb5b97d8cd60064c6bfd0d7921e4f96c185c8 (diff)
downloadruamel.yaml-53a39bcc144e46221caee39f49cd753f956b0657.tar.gz
udpate setup.py to workaround issue in setuptools0.16.11
https://github.com/pypa/setuptools/issues/2355#issuecomment-685159580
Diffstat (limited to 'emitter.py')
-rw-r--r--emitter.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/emitter.py b/emitter.py
index 41dc3e8..99e8abe 100644
--- a/emitter.py
+++ b/emitter.py
@@ -169,14 +169,14 @@ class Emitter(object):
self.prefixed_colon = self.colon if prefix_colon is None else prefix_colon + self.colon
# single entry mappings in flow sequence
self.brace_single_entry_mapping_in_flow_sequence = (
- brace_single_entry_mapping_in_flow_sequence
- ) # NOQA
+ brace_single_entry_mapping_in_flow_sequence # NOQA
+ )
# Formatting details.
self.canonical = canonical
self.allow_unicode = allow_unicode
# set to False to get "\Uxxxxxxxx" for non-basic unicode like emojis
- self.unicode_supplementary = sys.maxunicode > 0xffff
+ self.unicode_supplementary = sys.maxunicode > 0xFFFF
self.sequence_dash_offset = block_seq_indent if block_seq_indent else 0
self.top_level_colon_align = top_level_colon_align
self.best_sequence_indent = 2