summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAnthon van der Neut <anthon@mnt.org>2019-07-12 08:01:59 +0200
committerAnthon van der Neut <anthon@mnt.org>2019-07-12 08:01:59 +0200
commit1a6f9f94ed7e2322f75cf1d4ca15254205c8a856 (patch)
tree141e267c58c61437212dfabb5dac160800d2f2c8 /setup.py
parent745311fad7d45c0721cf4ed1903b56057939726a (diff)
downloadruamel.yaml-1a6f9f94ed7e2322f75cf1d4ca15254205c8a856.tar.gz
add py.typed to distribution0.15.99
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 10 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 9b15f4e..5d9dc9e 100644
--- a/setup.py
+++ b/setup.py
@@ -656,6 +656,12 @@ class NameSpacePackager(object):
and only adding defaults when no explicit entries were provided.
Add explicit Python versions in sync with tox.env generation based on python_requires?
"""
+ attr = '_' + sys._getframe().f_code.co_name
+ if not hasattr(self, attr):
+ setattr(self, attr, self._setup_classifiers())
+ return getattr(self, attr)
+
+ def _setup_classifiers(self):
return sorted(
set(
[
@@ -760,6 +766,10 @@ class NameSpacePackager(object):
df.append('LICENSE')
# but don't install it
exclude_files.append('LICENSE')
+ debug('testing<<<<<')
+ if 'Typing :: Typed' in self.classifiers:
+ debug('appending')
+ df.append('py.typed')
pd = self._pkg_data.get('package_data', {})
if df:
pd[self.full_package_name] = df