summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAnthon van der Neut <anthon@mnt.org>2021-08-19 07:40:56 +0200
committerAnthon van der Neut <anthon@mnt.org>2021-08-19 07:40:56 +0200
commit2869dc3337e9becee14b36c2cd28471ee5f579f1 (patch)
tree51ad1317cf12efee98b516eb3ea87e469b749f38 /setup.py
parentfda42f07ba3c70bf093818ef5e6d04704d7d1f5e (diff)
downloadruamel.yaml-2869dc3337e9becee14b36c2cd28471ee5f579f1.tar.gz
fix issues 389 and 3920.17.11
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 4 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 9ec5bcb..a6632f1 100644
--- a/setup.py
+++ b/setup.py
@@ -50,10 +50,6 @@ if sys.version_info < (3, 4):
pass
-if sys.version_info >= (3, 8):
- from ast import Str, Num, Bytes, NameConstant # NOQA
-
-
if sys.version_info < (3,):
open_kw = dict()
else:
@@ -81,6 +77,9 @@ else:
print('{:%Y-%d-%mT%H:%M:%S}'.format(datetime.datetime.now()), file=fp, end=' ')
print(*args, **kw1)
+if sys.version_info >= (3, 8):
+ from ast import Str, Num, Bytes, NameConstant # NOQA
+
def literal_eval(node_or_string):
"""
@@ -856,7 +855,7 @@ class NameSpacePackager(object):
return False
with open(file_name, 'w') as fp:
if os.path.exists('LICENSE'):
- fp.write('[metadata]\nlicense-file = LICENSE\n')
+ fp.write('[metadata]\nlicense_file = LICENSE\n')
else:
print('\n\n>>>>>> LICENSE file not found <<<<<\n\n')
if self._pkg_data.get('universal'):