summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAnthon van der Neut <anthon@mnt.org>2016-02-29 17:42:51 +0100
committerAnthon van der Neut <anthon@mnt.org>2016-02-29 17:42:51 +0100
commit5139e5f0cd2f28dc0737ab88c60dd39f18c48d86 (patch)
tree805d8c8a822009de285dbefae7d4723d946154cd /setup.py
parent0e9b775bedc021ebbf0b690da83c3172fe55df5a (diff)
downloadruamel.yaml-5139e5f0cd2f28dc0737ab88c60dd39f18c48d86.tar.gz
trigger read-the-docs0.11.6
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 3707cf4..0f81d70 100644
--- a/setup.py
+++ b/setup.py
@@ -234,7 +234,11 @@ class NameSpacePackager(object):
self._pkg = [None, None] # required and pre-installable packages
if sys.argv[0] == 'setup.py' and sys.argv[1] == 'install' and \
'--single-version-externally-managed' not in sys.argv:
+ if os.environ.get('READTHEDOCS', None) == 'True':
+ os.system('pip install .')
+ sys.exit(0)
print('error: you have to install with "pip install ."')
+ o
sys.exit(1)
# If you only support an extension module on Linux, Windows thinks it
# is pure. That way you would get pure python .whl files that take