summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAnthon van der Neut <anthon@mnt.org>2020-09-03 20:40:51 +0200
committerAnthon van der Neut <anthon@mnt.org>2020-09-03 20:40:51 +0200
commit53a39bcc144e46221caee39f49cd753f956b0657 (patch)
treeb45181ad4864f66157be031648da1bfa2e4baab5 /setup.py
parentb3acb5b97d8cd60064c6bfd0d7921e4f96c185c8 (diff)
downloadruamel.yaml-53a39bcc144e46221caee39f49cd753f956b0657.tar.gz
udpate setup.py to workaround issue in setuptools0.16.11
https://github.com/pypa/setuptools/issues/2355#issuecomment-685159580
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 3 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index f22dceb..40aba3a 100644
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,6 @@
# # header
# coding: utf-8
-# dd: 20200125
+# dd: 20200903
from __future__ import print_function, absolute_import, division, unicode_literals
@@ -446,10 +446,8 @@ class NameSpacePackager(object):
sys.exit(1)
def check(self):
- try:
- from pip.exceptions import InstallationError
- except ImportError:
- return
+ # https://github.com/pypa/setuptools/issues/2355#issuecomment-685159580
+ InstallationError = Exception
# arg is either develop (pip install -e) or install
if self.command not in ['install', 'develop']:
return