summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAnthon van der Neut <anthon@mnt.org>2019-02-27 22:57:46 +0100
committerAnthon van der Neut <anthon@mnt.org>2019-02-27 22:57:46 +0100
commitc716679edf348ba59d7551600c9cf139e23961ef (patch)
tree853ee5edd3b44aa67e182bb36b983dbb4ecf8f45 /setup.py
parent17af0e7a084955b5c0bf4124bba87190ac16734d (diff)
downloadruamel.yaml-c716679edf348ba59d7551600c9cf139e23961ef.tar.gz
fix issue #279 block sequence elements with flow mapping collapsed0.15.89
*When this change indeed resolves your problem, please **Close** this issue*. *(You can do so using the WorkFlow pull-down (close to the top right of this page))*
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 4 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 5b60dd1..9b15f4e 100644
--- a/setup.py
+++ b/setup.py
@@ -434,7 +434,7 @@ class NameSpacePackager(object):
while fpn:
self._split.insert(0, '.'.join(fpn))
fpn = fpn[:-1]
- for d in os.listdir('.'):
+ for d in sorted(os.listdir('.')):
if not os.path.isdir(d) or d == self._split[0] or d[0] in '._':
continue
# prevent sub-packages in namespace from being included
@@ -450,7 +450,9 @@ class NameSpacePackager(object):
(y.encode('utf-8') if isinstance(y, unicode) else y) for y in self._split
]
if skip:
- print('skipping sub-packages:', ', '.join(skip))
+ # this interferes with output checking
+ # print('skipping sub-packages:', ', '.join(skip))
+ pass
return self._split
@property