summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES5
-rw-r--r--README.rst3
-rw-r--r--__init__.py4
-rw-r--r--setup.py7
4 files changed, 14 insertions, 5 deletions
diff --git a/CHANGES b/CHANGES
index f16e8ed..db18d12 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,4 +1,7 @@
-0.14.0: 2017-03-22
+[0, 14, 2]: 2017-03-23
+ - fix for old default pip on Ubuntu 14.04 (reported by Sébastien Maccagnoni-Munch)
+
+0.14.1: 2017-03-22
- fix Text not available on 3.5.0 and 3.5.1 (reported by Charles Bouchard-Légaré)
0.14.0: 2017-03-21
diff --git a/README.rst b/README.rst
index b27c1ac..ed80389 100644
--- a/README.rst
+++ b/README.rst
@@ -18,6 +18,9 @@ ChangeLog
.. should insert NEXT: at the beginning of line for next key
+0.14.2 (2017-03-23):
+ - fix for old default pip on Ubuntu 14.04 (reported by Sébastien Maccagnoni-Munch)
+
0.14.1 (2017-03-22):
- fix Text not available on 3.5.0 and 3.5.1 (reported by Charles Bouchard-Légaré)
diff --git a/__init__.py b/__init__.py
index 8a21e45..dd2b468 100644
--- a/__init__.py
+++ b/__init__.py
@@ -10,8 +10,8 @@ from typing import Dict, Any # NOQA
_package_data = dict(
full_package_name='ruamel.yaml',
- version_info=(0, 14, 1),
- __version__='0.14.1',
+ version_info=(0, 14, 2),
+ __version__='0.14.2',
author='Anthon van der Neut',
author_email='a.van.der.neut@ruamel.eu',
description='ruamel.yaml is a YAML parser/emitter that supports roundtrip preservation of comments, seq/map flow style, and map key order', # NOQA
diff --git a/setup.py b/setup.py
index eafeb1f..c3ccef2 100644
--- a/setup.py
+++ b/setup.py
@@ -815,8 +815,11 @@ def main():
print(' "{0}": "{1}",'.format(k, v))
if dump_kw in sys.argv:
sys.argv.remove(dump_kw)
- with open('README.rst') as fp:
- kw['long_description'] = fp.read()
+ try:
+ with open('README.rst') as fp:
+ kw['long_description'] = fp.read()
+ except:
+ pass
if nsp.wheel(kw, setup):
return
for x in ['-c', 'egg_info', '--egg-base', 'pip-egg-info']: