summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorRaphaël Barrois <raphael.barrois@polytechnique.org>2016-02-12 01:28:24 +0100
committerRaphaël Barrois <raphael.barrois@polytechnique.org>2016-02-12 01:28:24 +0100
commit52f57bb0fd9bd6edeb71d9d517069dca6531565e (patch)
treec2a14b62c2cab4fc75ab201b0ec0167b56989ac2 /Makefile
parent60076c03746c68fae570805997b38f79228b1e63 (diff)
downloadsemantic-version-52f57bb0fd9bd6edeb71d9d517069dca6531565e.tar.gz
Update test targets.
Drop support for Django 1.4; go up to 1.9
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 4b394e1..15d9d88 100644
--- a/Makefile
+++ b/Makefile
@@ -6,7 +6,7 @@ DOC_DIR=docs
COVERAGE = python $(shell which coverage)
# Dependencies
-DJANGO_VERSION ?= 1.8
+DJANGO_VERSION ?= 1.9
PYTHON_VERSION := $(shell python --version)
NEXT_DJANGO_VERSION=$(shell python -c "v='$(DJANGO_VERSION)'; parts=v.split('.'); parts[-1]=str(int(parts[-1])+1); print('.'.join(parts))")
@@ -17,12 +17,12 @@ all: default
default:
-install-deps: auto_dev_requirements_django$(DJANGO_VERSION).txt
+install-deps: auto_dev_requirements_django_$(DJANGO_VERSION).txt
pip install --upgrade pip setuptools
pip install --upgrade -r $<
pip freeze
-auto_dev_requirements_%.txt: dev_requirements_%.txt dev_requirements.txt requirements.txt
+auto_dev_requirements_%.txt: dev_requirements.txt requirements.txt
grep --no-filename "^[^#-]" $^ | grep -v "^Django" > $@
echo "Django>=$(DJANGO_VERSION),<$(NEXT_DJANGO_VERSION)" >> $@