summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorRaphaël Barrois <raphael.barrois@polytechnique.org>2019-08-20 22:55:10 +0200
committerRaphaël Barrois <raphael.barrois@polytechnique.org>2019-08-24 15:13:09 +0200
commita7c2b75d48587fce826613efced163272b11e354 (patch)
treec022cf3401dce1a1ab98394c35ff4c85fd980811 /Makefile
parent36f5b30d2fb6ad535b322a875c8bfb297e97aacc (diff)
downloadsemantic-version-a7c2b75d48587fce826613efced163272b11e354.tar.gz
Lint test code.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 626f21c..ecf30e0 100644
--- a/Makefile
+++ b/Makefile
@@ -32,9 +32,13 @@ test:
python -W default setup.py test
# Note: we run the linter in two runs, because our __init__.py files has specific warnings we want to exclude
-lint:
+lint: check-manifest flake8
+
+check-manifest:
check-manifest
- $(FLAKE8) --config .flake8 --exclude $(PACKAGE)/__init__.py $(PACKAGE)
+
+flake8:
+ $(FLAKE8) --config .flake8 --exclude $(PACKAGE)/__init__.py $(PACKAGE) $(TESTS_DIR)
$(FLAKE8) --config .flake8 --ignore F401 $(PACKAGE)/__init__.py
coverage: