summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorRaphaël Barrois <raphael.barrois@polyconseil.fr>2016-09-01 13:23:12 +0200
committerRaphaël Barrois <raphael.barrois@polyconseil.fr>2016-09-01 13:23:12 +0200
commitbe455e8998ff8445db15476a4da1d5e3e293eab4 (patch)
treeb55ad92485b3df66f5480acf785bfa550408aed0 /Makefile
parentf514edb523f01dd8a7da4c56d2ce077b30e630ab (diff)
downloadsemantic-version-be455e8998ff8445db15476a4da1d5e3e293eab4.tar.gz
Add support for Django 1.10
Stop coercing fields magically: >>> a = SomeModel() >>> a.version = '0.1.0' >>> a.version '0.1.0' >>> a.full_clean() >>> a.version Version('0.1.0') Closes #43, #45
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 15d9d88..52b8e8b 100644
--- a/Makefile
+++ b/Makefile
@@ -6,7 +6,7 @@ DOC_DIR=docs
COVERAGE = python $(shell which coverage)
# Dependencies
-DJANGO_VERSION ?= 1.9
+DJANGO_VERSION ?= 1.10
PYTHON_VERSION := $(shell python --version)
NEXT_DJANGO_VERSION=$(shell python -c "v='$(DJANGO_VERSION)'; parts=v.split('.'); parts[-1]=str(int(parts[-1])+1); print('.'.join(parts))")