summaryrefslogtreecommitdiff
path: root/setup.cfg
diff options
context:
space:
mode:
authorRaphaël Barrois <raphael.barrois@polytechnique.org>2021-03-02 11:20:51 +0100
committerRaphaël Barrois <raphael.barrois@polytechnique.org>2021-03-02 16:19:57 +0100
commit306fbe1b2222d218c62c2ddb32d91eeea8957951 (patch)
tree55ae88e68f6a04c0c34c252deeadb13b27e336d8 /setup.cfg
parent8ed1ec495a716c2e2dc7fb6df28c086e35a8950e (diff)
downloadsemantic-version-306fbe1b2222d218c62c2ddb32d91eeea8957951.tar.gz
Move package metadata to setup.cfg
Instead of relying on setup.py, use setup.cfg. Dev/doc requirements have been moved there as well, under the `doc` and `dev` extras.
Diffstat (limited to 'setup.cfg')
-rw-r--r--setup.cfg57
1 files changed, 51 insertions, 6 deletions
diff --git a/setup.cfg b/setup.cfg
index e6ff787..3e5e632 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,15 +1,60 @@
-[bdist_wheel]
-universal = 1
-
[metadata]
+name = semantic_version
+version = 2.8.6.dev0
+description = A library implementing the 'SemVer' scheme.
+long_description = file: README.rst
+# https://docutils.sourceforge.io/FAQ.html#what-s-the-official-mime-type-for-restructuredtext-data
+long_description_content_type = text/x-rst
+author = Raphaël Barrois
+author_email = raphael.barrois+semver@polytechnique.org
+url = https://github.com/rbarrois/python-semanticversion
+keywords = semantic version, versioning, version
+license = BSD
license_file = LICENSE
+classifiers =
+ Development Status :: 5 - Production/Stable
+ Intended Audience :: Developers
+ License :: OSI Approved :: BSD License
+ Topic :: Software Development :: Libraries :: Python Modules
+ Operating System :: OS Independent
+ Programming Language :: Python
+ Programming Language :: Python :: 2.7
+ Programming Language :: Python :: 3
+ Programming Language :: Python :: 3.4
+ Programming Language :: Python :: 3.5
+ Programming Language :: Python :: 3.6
+ Programming Language :: Python :: 3.7
+ Topic :: Software Development :: Libraries :: Python Modules
+
+[options]
+zip_safe = false
+packages = semantic_version
+python_requires = >= 2.7
+install_requires =
+
+[options.extras_require]
+dev =
+ Django>=1.11
+ # Runners
+ tox
+ # Quality
+ check_manifest
+ coverage
+ flake8
+ # Packaging
+ wheel
+ zest.releaser[recommended]
+
+doc =
+ Sphinx
+ sphinx_rtd_theme
+
+[bdist_wheel]
+universal = 1
[zest.releaser]
; semver-style versions
version-levels = 3
-; Version flag location (we use __version__)
-python-file-with-version = semantic_version/__init__.py
-
[distutils]
index-servers = pypi