summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRaphaël Barrois <raphael.barrois@polytechnique.org>2012-05-16 00:53:17 +0200
committerRaphaël Barrois <raphael.barrois@polytechnique.org>2012-05-16 00:53:17 +0200
commit0b766cf96d4b0fc900fe65dc52ab8aef101bace3 (patch)
tree4476bbd3d2c8616a22c92d5e54d058e809ac1a46 /setup.py
parentc57899e853ddf5161b53df3bad82accfe0873f6e (diff)
downloadsemantic-version-0b766cf96d4b0fc900fe65dc52ab8aef101bace3.tar.gz
Fix setup.py
Signed-off-by: Raphaël Barrois <raphael.barrois@polytechnique.org>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 002cd44..3cf8ed8 100755
--- a/setup.py
+++ b/setup.py
@@ -12,7 +12,7 @@ root_dir = os.path.abspath(os.path.dirname(__file__))
def get_version():
- version_re = re.compile(r"^__version__ = '([\w_.]+)'$")
+ version_re = re.compile(r"^__version__ = '([\w_.-]+)'$")
with open(os.path.join(root_dir, 'src', 'semantic_version', '__init__.py')) as f:
for line in f:
match = version_re.match(line[:-1])