summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRaphaël Barrois <raphael.barrois@polytechnique.org>2021-03-02 11:20:51 +0100
committerRaphaël Barrois <raphael.barrois@polytechnique.org>2021-03-02 16:19:57 +0100
commit306fbe1b2222d218c62c2ddb32d91eeea8957951 (patch)
tree55ae88e68f6a04c0c34c252deeadb13b27e336d8 /setup.py
parent8ed1ec495a716c2e2dc7fb6df28c086e35a8950e (diff)
downloadsemantic-version-306fbe1b2222d218c62c2ddb32d91eeea8957951.tar.gz
Move package metadata to setup.cfg
Instead of relying on setup.py, use setup.cfg. Dev/doc requirements have been moved there as well, under the `doc` and `dev` extras.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py67
1 files changed, 1 insertions, 66 deletions
diff --git a/setup.py b/setup.py
index 7ad8d5f..02a989b 100755
--- a/setup.py
+++ b/setup.py
@@ -3,71 +3,6 @@
# Copyright (c) The python-semanticversion project
-import codecs
-import os
-import re
-
from setuptools import setup
-root_dir = os.path.abspath(os.path.dirname(__file__))
-
-
-def get_version(package_name):
- version_re = re.compile(r"^__version__ = [\"']([\w_.-]+)[\"']$")
- package_components = package_name.split('.')
- init_path = os.path.join(root_dir, *(package_components + ['__init__.py']))
- with codecs.open(init_path, 'r', 'utf-8') as f:
- for line in f:
- match = version_re.match(line[:-1])
- if match:
- return match.groups()[0]
- return '0.1.0'
-
-
-def clean_readme(fname):
- """Cleanup README.rst for proper PyPI formatting."""
- with codecs.open(fname, 'r', 'utf-8') as f:
- return ''.join(
- re.sub(r':\w+:`([^`]+?)( <[^<>]+>)?`', r'``\1``', line)
- for line in f
- if not (line.startswith('.. currentmodule') or line.startswith('.. toctree'))
- )
-
-
-PACKAGE = 'semantic_version'
-
-
-setup(
- name=PACKAGE,
- version=get_version(PACKAGE),
- author="Raphaël Barrois",
- author_email="raphael.barrois+semver@polytechnique.org",
- description="A library implementing the 'SemVer' scheme.",
- long_description=clean_readme('README.rst'),
- license='BSD',
- keywords=['semantic version', 'versioning', 'version'],
- url='https://github.com/rbarrois/python-semanticversion',
- download_url='http://pypi.python.org/pypi/semantic_version/',
- packages=['semantic_version'],
- python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*",
- setup_requires=[
- 'setuptools>=0.8',
- ],
- zip_safe=False,
- classifiers=[
- 'Development Status :: 5 - Production/Stable',
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: BSD License',
- 'Topic :: Software Development :: Libraries :: Python Modules',
- 'Operating System :: OS Independent',
- 'Programming Language :: Python',
- 'Programming Language :: Python :: 2.7',
- 'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.4',
- 'Programming Language :: Python :: 3.5',
- 'Programming Language :: Python :: 3.6',
- 'Programming Language :: Python :: 3.7',
- 'Topic :: Software Development :: Libraries :: Python Modules'
- ],
- test_suite='tests',
-)
+setup()