summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRaphaël Barrois <raphael.barrois@polytechnique.org>2012-05-15 00:28:28 +0200
committerRaphaël Barrois <raphael.barrois@polytechnique.org>2012-05-15 00:28:28 +0200
commitafedbb4f3d970e554195494bee1cae3218b1a607 (patch)
tree5ca479004fe5b2d6eb23ccc4a0b7933622fdf111 /setup.py
parent000d85887ebc649e78a6142b145a712619f4c4a4 (diff)
downloadsemantic-version-afedbb4f3d970e554195494bee1cae3218b1a607.tar.gz
Use unittest2 loader.discover for python2.6
Signed-off-by: Raphaël Barrois <raphael.barrois@polytechnique.org>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index b2fc16d..002cd44 100755
--- a/setup.py
+++ b/setup.py
@@ -41,7 +41,11 @@ class test(cmd.Command):
def run(self):
"""Run the test suite."""
- import unittest
+ try:
+ import unittest2 as unittest
+ except ImportError:
+ import unittest
+
if self.verbose:
verbosity=1
else: