summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorYu-Jie Lin <livibetter@gmail.com>2013-08-26 11:50:45 +0800
committerYu-Jie Lin <livibetter@gmail.com>2013-08-26 11:50:45 +0800
commit96e7daeaf178c8460547c8358dad001eea6d61e4 (patch)
tree23610377943b2d166de8bcdf36fc8cb205ef999b /Makefile
parent0c5a75de036c42e9e72da7636501df65606eb5f1 (diff)
downloadsmartypants-96e7daeaf178c8460547c8358dad001eea6d61e4.tar.gz
only generate documentation when necessary
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 06b47da..a77bd3c 100644
--- a/Makefile
+++ b/Makefile
@@ -15,6 +15,8 @@ VENV_PY3_CMD=virtualenv-python3.2
BUILD_CMD=./setup.py sdist --formats gztar,zip bdist_wininst --plat-name win32
+DOC_FILES = docs/conf.py $(wildcard docs/*.rst)
+
# ============================================================================
build:
@@ -28,7 +30,9 @@ upload_doc: doc
# ============================================================================
-doc: smartypants_command.py
+doc: docs/_build/html
+
+docs/_build/html: $(DOC_FILES) smartypants.py smartypants_command.py
make -C docs html
smartypants_command.py: smartypants