summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorYu-Jie Lin <livibetter@gmail.com>2013-08-14 13:48:43 +0800
committerYu-Jie Lin <livibetter@gmail.com>2013-08-14 13:48:43 +0800
commit7f138eb8923c1eda0e8ff5fd8d0f1968cfdeba64 (patch)
tree02219a11b850969b6f6e56e4cf89758d6e8b6d1b /tests
parenta439633a0421453a4d58ed480d795cfd8368b44a (diff)
downloadsmartypants-7f138eb8923c1eda0e8ff5fd8d0f1968cfdeba64.tar.gz
add long_description and test, edit README and setup
Diffstat (limited to 'tests')
-rw-r--r--tests/test_setup.py22
1 files changed, 22 insertions, 0 deletions
diff --git a/tests/test_setup.py b/tests/test_setup.py
new file mode 100644
index 0000000..6f5f636
--- /dev/null
+++ b/tests/test_setup.py
@@ -0,0 +1,22 @@
+# Copyright (c) 2013 Yu-Jie Lin
+# Licensed under the BSD License, for detailed license information, see COPYING
+
+from docutils.core import publish_string
+import unittest
+
+
+class SetupTestCase(unittest.TestCase):
+
+ def test_long_description(self):
+ """Ensure long description can be generated"""
+ with open('README-PyPI.rst') as f:
+ long_description = f.read()
+
+ overrides = {
+ # raises exception at warning level (2)
+ 'halt_level': 2,
+ 'raw_enabled': False,
+ }
+ html = publish_string(long_description, writer_name='html',
+ settings_overrides=overrides)
+ self.assertTrue(html)